Sign-in / Sign-up
Your question
Closed

PSU squealing

Tags:
  • Power Supplies
  • Computers
  • Components
Last response: in Components
January 3, 2009 12:07:34 PM

Hello guys , im from Brazil and im having problems with my system.
So , every time that my computer is under full load , for exemple when i start to play Crysis , the PSU makes a higher noise . I tried to change the PSU , my old was a ULTRA x3 1000w , but the noise still. I dont know whats happening and no one ( here in BRAZIL ) knows what to do. Hope you guys can help-me to fix . The noise likes a squeal/ whining noise .

Thanks guys

More about : psu squealing

January 3, 2009 12:25:38 PM

Get an ups/AVR BOOST/TRIM device. How bad is your power coming out of the wall there? Also could be a grounding problem do you ever get shocked from it? Is your mobo touching the tray/case. Do you have a PWSPLY TESTER? What are the exact PWR SPLY MODEL NUMBERS. These are things that could cause your pwr supply to make weird noises or even fail. If you buy cheap high wattage PSU's though you might not actually be getting your money/WATT's worth and might be overloading it. Also a quick parts list will help.
January 3, 2009 12:35:30 PM

My actual PSU is a CORSAIR 1000hx , and im not sure about how bad is the power coming out the wall, but i think that its fine. I never had this problem before , im gonna check if the MOBO is touching the case , but im sure that it isnt.
Related resources
January 3, 2009 12:49:54 PM

mkamachi said:
Hello guys , im from Brazil and im having problems with my system.
So , every time that my computer is under full load , for exemple when i start to play Crysis , the PSU makes a higher noise . I tried to change the PSU , my old was a ULTRA x3 1000w , but the noise still. I dont know whats happening and no one ( here in BRAZIL ) knows what to do. Hope you guys can help-me to fix . The noise likes a squeal/ whining noise .

Thanks guys


Nvidia video cards have a pizo speaker - if the power is not connected it will squeal?
January 3, 2009 1:45:56 PM

pizo speaker ? what is this ?

Im sure the power conector is plugged , but the VGA is fine, i guess. The problem is the PSU , it gets noisier under full load . I dont know if the vga is causing this issue on my PSU .
The other guy told me that if the MOBO was touching the case , it could be causing the noise coming form the PSU. is it possible?
a c 144 ) Power supply
January 3, 2009 1:53:25 PM

One thing that you could try is to breadboard (build it outside the case) the complete system. Then see if it is still making the same noise.
January 3, 2009 2:07:03 PM

Yes , i will try this ...that one thing that i didn't try before ....is there any problem if i put the MOBO just on the table ? or i have to put something under the MOBO ?
January 3, 2009 2:10:43 PM


Does it do this with all games or just Crysis?
January 3, 2009 2:20:08 PM

Since i bought the new PSU , i just tested it with Crysis , but every 3d aplication makes my PSU get noisier . When im using the NVIDIA tools i can hear the same noise ...so , its not a crysis bug for sure.
January 3, 2009 2:55:56 PM

It is your video card
Lemme guess ... an 8800GT? Maybe made by EVGA?
Maybe not but if its only acting up in 3d application it is almost certainly your video card. My buddy had an 8800GT that did that.
January 3, 2009 9:11:28 PM

No , i have a GTX 280 SLi , and yes its made by EVGA ...what could be happening with my VGA ?because it looks like its working fine.Is there any relate between the noise coming from the PSU and the problem with the VGA ?
January 3, 2009 10:41:57 PM

A capacitor in the graphics card could be what is causing the whining noise. Try just one video card, then the other. Really try to isolate where the noise is coming from.
January 4, 2009 5:54:53 PM

I already know where the noise comes from, its coming from the PSU . The only thing that i need to know is why its happening.
January 4, 2009 8:04:36 PM

Ok have it your way. You have noise coming from your computer with two different PSUs only in 3D mode. You have changed out the PSU yet you still insist it is the PSU. I am assuming you haven't changed out the video cards to see if the noise goes away when you use a different video card. It is simple troubleshooting 101. Eliminate possible causes of the problem one component at a time. If you have then I apologize for assuming you haven't, what troubleshooting steps have you tried so far? How did you come to the conclusion it is the PSU.?
January 5, 2009 8:58:40 AM

skywalker9952 said:
It is your video card
Lemme guess ... an 8800GT? Maybe made by EVGA?
Maybe not but if its only acting up in 3d application it is almost certainly your video card. My buddy had an 8800GT that did that.


Had an 8600GT with it aswell - 3D mode sucks more power and makes it sound different.
January 5, 2009 12:25:47 PM

Let me try to explain , im not sure that the problem is the PSU , i just said that i heard the noise and it was coming from the PSU, but i dont know whats the prioblem ...it could be the VGA too .
January 5, 2009 12:33:20 PM

I'd agree with the video cards being the culprit. The same thing happens with my 4870x2. High powered video cards can create a great deal of capacitor whine (usually very high pitch and electrical sounding).
January 8, 2009 7:35:49 AM

Malovane said:
I'd agree with the video cards being the culprit. The same thing happens with my 4870x2. High powered video cards can create a great deal of capacitor whine (usually very high pitch and electrical sounding).


Makes me wonder, shorter lifespan aka faulty components?
January 12, 2009 9:49:18 AM

I dont think so , im sure that the noise isnt normal...
January 12, 2009 10:07:44 AM

My 8800gt makes some noise when switching video modes, it is especially noticeable in Crysis when the game is loading and the various video intro' get played .. its okay once in the game though. Bit worried now, is it a sign of failure?
January 13, 2009 11:02:24 AM

yeah , it could be a sign that something isnt working fine... My power supply makes this **** noise , and i cant find way to fix it ...im getting crazy man , i changed the PSU and the noise still , i think the VGA is the problem .
a b ) Power supply
May 25, 2011 8:30:13 PM

This topic has been closed by Mousemonkey