Sign in with
Sign up | Sign in
Your question

HIS Radeon HD 3850-Problem

Last response: in Graphics & Displays
Share
November 7, 2008 2:20:18 AM

I got this card yesterday from New Egg. Installed it using the drivers that came with it. Everything seemed fine. I started playing Far Cry 2 (single player), played for a couple hours. Then played COD 4 online. About an hour and a half later, the screen froze and locked up. (The card seemed kind of hot) Had to reboot.

Now the problem: The card won't run in windows.
When I start the PC I can see the ASUS graphic, then the usual white letters Fast track; Drives; etc. with a black screen behind - only this time there is a grid of "dots" about a 1/4" apart all over the screen. Then comes the Windows graphic with the white horizontal bar across the bottom. In this screen there are vertical lines intermittent with the background. When this gets done loading, just before windows really starts, my LCD monitor goes off.

I was able to run windows in "safe mode" and tried to uninstall and reinstall all the drivers. But still can't get the card to run in windows. It always shuts off at the same point.

I have an ASUS A8V Deluxe MotherBoard. After playing with the drivers for a while (with no luck). I went into the BIOS, under the AGP settings it lists the memory as 32,64,128,256. The card has 512Mb and the BIOS was set to 256, which is my current ATI Radeon X850 Pro card. Can I run the HIS HD graphics card on this mother board??? It ran fine for a couple hours........or did I fry something on the card???

ASUS A8V Deluxe
AMD Athlon 64 FX55@2.60 Ghz
Kingston Hyper X 512MB x 4 sticks
Cooler Master Real Power 550 Watts

More about : radeon 3850 problem

November 7, 2008 8:17:24 AM

I would send it back. You have only had it for a day and it appears to be faulty. I would also not put anymore money into that system especially because its agp.
November 7, 2008 10:31:11 AM

^+1
!