USB flash drive write protected

Hello,

I received a USB flash drive as a souvenir at a conference. I dont have the instructions with me anymore. When I plug it in, it shows one file on the drive 'login.exe'. The drive capacity is showing as 250 KB (should be 1 GB). And windows says that its write-protected.

The 'login.exe' asks for a password and irrespective of anything I type, it just exits with no message. The 'login.exe' also has a change password option which asks for the old password and new password. Irrespective of whatever I give, it always says "password successfully changed". But when I give this password to login again, nothing happens as usual.

I tried a low-level format utility but it said that the disk did not have 65535 sectors. I've searched and tried a number of things but nothing works. It still shows the wrong capacity and disk is write-protected. (PS. there is no switch to turn off write-protection on the drive.)
1 answer Last reply
More about flash drive write protected
  1. Try this:

    USB Flash drive tester

    http://downloads.zdnet.co.uk/0,1000000375,39364218s,00.htm

    The pen drive may be bad and need replacement.
Ask a new question

Read More

Flash Media Login USB Flash Storage