Sign in with
Sign up | Sign in
Your question

Botting from USB flash drive on GA-965PDQ6 board?

Last response: in Motherboards
Share
February 10, 2009 8:28:44 PM

Hi.

I've been trying to boot from USB flash drives using a GA-965PDQ6 motherboard. One flash drive has bartpe on it created with petousb and the other flash drive has Acronis True Image 12 recovery files on it made from the main prgoram itself for that purpose.

However, no matter any of the settings I've tried in the bios, the USB gets ignored. I've tried booting from all USB related settings, i.e. USB FDD, CD-ROM, ZIP. There was originally a setting in the main drive boot order to boot from a USB HDD but when I set it to boot from this the setting just disappeared probably because I don't have a USB HDD!

I have two HDDs, one SATA and one IDE, and two optical drives, one SATA and one IDE. the rest of the setup re chips, graphics, RAM etc. is the run of the mill for this board.

My main concern is can anyone inform me how to boot from USB flash drives with this board?

Also, I want to buy an external HDD, and as the USB HDD setting no longer exists in the bios, even after flashing to F13, how will I get it to be recognised?

Cheers!
a c 236 V Motherboard
February 11, 2009 1:30:25 AM

Won't pressing F12 at POST bring up the list of available devices?
Related resources
February 11, 2009 5:58:02 PM

Yes, that was it, silly me. F12 and set USB HDD as boot device and voila, flash drive boots. Thanks.
February 11, 2009 6:44:09 PM

So what happened to the USB HDD feature in the Advanced Bios Features screen of the BIOS? It was there and disappeared when I set it to boot first from that and hasn't been replaced with a newly flashed bios?

At present I have to boot True Iamge flash drive by setting USB FDD in Advanced Bios Features and pressing F12 to boot from USB HDD?
February 11, 2009 7:30:34 PM

bilbat said:
Excellent tutorial on USB booting/BIOS flashing here:

http://forums.tweaktown.com/f69/bios-flashing-how-qflas...


I made a USB flash drive bootable in theory by following the guide with the given tools. I did this twice. But the flash drive didn't boot, just went into the OS.

Same thing for the PEtoUSB I made from a BartPE CD. Just won't boot from USB flash drive.

The only flash drive that boots is the one made by Acronis' own tool for booting a recovery USB flash drive.

I think I'm not doing the BIOS boot settings right? Why doesn't a modern Gigabyte BIOS update give a USB flash drive setting?
a c 236 V Motherboard
February 11, 2009 8:01:48 PM

For the number of times that one boots from a USB key or from an alternate disk, isn't it more convenient to press F8 on an Asus motherboard or F12 on a Gigabyte motherboard at POST?
February 11, 2009 8:06:54 PM

OK. Flashed bios with f12.
Set 'Advanced bios Features' to boot from 'usb hdd' first device
Saved and rebooted, pressed f12 to enter boot order to choose usb hdd to boot from.

usb flash driver with true image 12 on BOOTS.

usb flash driver with ms-dos boot files on formatted with hpusbfw does NOT BOOT.

usb flash driver with bartpe on made from petousb does NOT BOOT.

:heink: 
a c 177 V Motherboard
February 12, 2009 2:30:29 PM

What do you have "Legacy USB storage detect" set to on the "Integrated peripherals" page of the BIOS? You want it 'enabled' to boot from USB; 'disabled' the rest of the time, as it's the source of a known 'reboot-loop' problem. GB boards are notoriously finicky about USB spec compliance; often, an older device simply will not work, AND will cause lots of strange problems. As for:
Quote:
Why doesn't a modern Gigabyte BIOS update give a USB flash drive setting?

For the same reason half the stuff you buy has problems; the manufacturer saved a million bucks by farming out the s'ware to the 'Elbonians', lost three milion trying to make it work even marginally, and then lost ten million worth of customer good will by releasing the result, bugs and all!
February 12, 2009 4:38:05 PM

"Legacy USB storage detect" is set to enable through optimised default bios settings.

I got the flash drive with bartpe on it to half boot once after setting the bios to boot from USB FDD but then the drive was never detected again after that.

True Image flash drive works 100% of the time with bios set to boot from USB HDD.

:pfff: 
a c 177 V Motherboard
February 13, 2009 12:01:24 PM

Then I believe you need to post a bug report to 'Bart', as it would appear to be a problem with his "Pre-Installed Environment"...
February 13, 2009 7:11:48 PM

Well not necessarily. I have an identical thumb drive to the one that boots True Image every time. I formatted it to the same FAT file system, made it active and used the same Media Builder program from Acronis to write the same files in the same way as the thumb drive that is booting.

and the idential drive will NOT boot the same program. thoust it was to do with active partitions but that didn't seem to be it. Might be something to do with where the formatting tool places the boot sector.

'tis a dark art.
February 13, 2009 7:46:48 PM

I have no idea why the first drive accepted True Image and boots from USB HDD setting every time.

I have 5 identical thumb drives.

i) One thumb drive accepted Acronis' Media Builder's emergency boot up files first time without formatting by me (just the factory fresh).

ii) Another identical thumb drive which was factory fresh and was not formatted by me (just as the first drive that works) was not formatted by me would NOT boot with Acronis' Media Builder's emergency boot up files.

iii) Another identical thumb drive which was formatted by me would NOT boot with Acronis' Media Builder's emergency boot up files.

I have tried formatting with Disk Management in Win2k and Vista, also HP USB Disk Storage Format Tool in both FAT and FAT32.

I'm going to now try a fourth identical thumb drive in the same way as the first but don't hold out much hope.
a c 177 V Motherboard
February 14, 2009 5:55:39 PM

The first thing i'd try is to do a plain old format from windoze, and simply select "make ms-dos bootable", and then see if they all boot - if so, you've eliminated any physical defects...

You likely need a tool that will let you look directly at, or edit, the MBR - the master boot record, on your drives;
http://www.aefdisk32.com/download/sharewareversion_en.h...
is a command line editor;
possibly:
http://premiumdatarecovery.info/?campaign=DataRecovery-...
or:
http://3d2f.com/programs/56-912-softambulance-partition...

I use BootIt NG to manage my EMBR/MBRs, but I'm hesitant to mess around with it experimenting; it took way too much effort to get all my EMBR/MBR swaps tuned perfectly for four OSs on two RAIDs - now, I've got a piece of black electrical tape on my monitor where the MBR editor selection pops up!
February 19, 2009 7:27:30 PM

One more usb falsh drive booted with true image but when I used the same drive for either booting from DOS [with DOS files added using the HP formatting utility] or bartpe [using PeToUsb], it wouldn't boot.

Boot sector tools would be an interesting avenue to investigate but me too time-restricted for researching boot sector stuff so can't be a priority with me methinks.

Thanks anyway.
a c 177 V Motherboard
February 19, 2009 7:50:21 PM

I simply have to believe , that if this will boot (from the same physical drive, with the same BIOS set-up) and that won't, the problem (and it could well be an intermittent one) pretty much has to be with the installer/formatter for the boot utilities, and the only way I know of to examine the actual situation is by looking at the master boot record...
February 25, 2009 6:28:09 PM

OK, I'm no expert, in fact I know nothing. Here is a screen grab of the drive that boots with acronis progs on...




...and this is the bumph...

WinHex 15.2 SR-2
25/02/2009, 20:04:49

Drive N:
File system: FAT16
Total capacity: 493,862,912 bytes = 471 MB
Sector count: 964,576
Usable sectors: 964,064
First data sector: 508
Bytes per sector: 512
Bytes per cluster: 8,192
Free clusters: 50,098 = 83% free
Total clusters: 60,254
FAT1 = FAT2
Clean shut down: Yes
I/O error-free: Yes

So what exactly am i looking for? Little question with a big answer!

February 25, 2009 8:50:39 PM

Oops, the right hand side of the screen grab didn't come out on in the pic on the web so here it is cropped from original...




Regards
February 25, 2009 8:55:51 PM

And here it is but this time saved for a 17" screen doh...




February 26, 2009 11:11:53 AM

The other drives are identical in brand but are smaller in size becaise they won't let me transfer an image from the bootable pen drive saying destination drive too small and showing a smaller sector size. Must be in the formatting unless the manufacturing process changed mid-line.
October 12, 2012 4:56:27 AM

Hi,
having tried may times with particular USB stick (ebay key) just wont work.
I have a USB stick to install OSX mac lion on a stick and it s recognized all the time and install successful :o 
Ensure AHCI is selected, USB-HDD first boot priority in Bios, and stick is in the front USB port
(thats the on i use anyway) and whoola. :bounce: 
After you enter bios to change boot priority, if the USB drive isnt listed chances are you Bios it's going to recognized it and just wont work ;) 
!