Sign in with
Sign up | Sign in
Your question

Western Digital VelociRaptor WD3000GLFS

Last response: in Storage
Share
March 18, 2010 4:46:09 AM

Hi, I have a Western Digital VelociRaptor WD3000GLFS 300GB 10k RPM Hard Drive.
It was working a few hours ago, but in the middle of a WoW raid, my computer shuts off suddenly and when I power it up again, on the POST screen, the Hard Drive is not detected, not even with a [None], but with a blank slot. I have tried switching the SATA ports and my DVD drive is working fine. This has happened before in the past but it has always worked after a few minutes of off time.

Is my Hard Drive dead, and if it is, is there a cheap way to recover some files? Should I try the "Freezer Trick"?

Motherboard: EVGA 790i Ultra
Graphics Card: PNY GTX 280
Sound Card: Razer Barracuda
RAM: DDR3 1066MHz 4 GB
CPU: Intel Core 2 Quad Q9550

Thanks...
March 18, 2010 4:48:42 AM

Oh, by the way, when it turns on it does seem to be working, no strange sounds or anything. I think it is a firmware issue, how can I resolve this?
March 18, 2010 5:20:06 AM

I found a thread on another site where the person posted an updated firmware from WD that they refuse to publicly release: http://hardforum.com/showthread.php?t=1452275 should I do this, and how would I go about doing this? Would this fix the problems I am having?

(To be honest, I don't think it is a hardware problem. The drive acts and sounds fine, but is just not showing up at all.)
March 18, 2010 5:40:53 AM

Sorry for the quadruple posts, but I am doing this from a mobile phone and some stuff isn't working well. I feel I should mention that before the incident, I was deleting a virus that had managed to imbed itself within several startup services and many key applications. After I had done so, there was an error message during startup stating that it was missing. Could that be a potential cause?
!