Sign in with
Sign up | Sign in
Your question
Closed

Problem with SB titanium X-FI (NOISE)

Last response: in Components
Share
January 7, 2009 6:11:44 PM

Hi everyone, I've used this Forum to solve so many problems, and now I need help for a problem that i can't solve.

My Specs:
Intel Q9650
Motherboard XFX 790i Ultra Sli
Ram 4gb DDR3
2 x GTX280 XFX 640MHz 1gb (SLI)
PSU 1000W Enermax Galaxy DXX
Windows Vista Ultimate 64-bit

And... a "lovely" Creative Sound Blaster X-Fi Titanium Fatal1ty PCIe

I have the sound card instaled, and with the drivers that came with it.
But I've got a problem. With some games it makes a noise... very disgusting (the sound is similir to the one that makes a radio when it can't get the freqency... interference, it sounds more or less like chakchkachakchakchakchak....).

It happened with Call Of Duty World at War when i throw a gas greanade (but it happens since i upgrade the drivers and the creative console so i downgrade it to the version of the cd and the problem was solved).

With other games like Grand Theft Auto IV it happens more. If you're in a place with Smoke it sounds and at the menu when you select things...

I noticed that if i use a lower audo Quality (the minimum quality that i can use is 16bits 44100MHz), the noise is lower than if I use a better quality (the bigest quality 24 bits and 9600MHz makes a very loud noise). I tried to desactivate the Sound Blaster enhacements and everything but the noise continues.

I think that i have enough PSU, and the Integrated audio card works perfectly (well the quality ofcouse is lower but it never fails, so I'm using it)

Sorry about my english.

I hope you'll find a way to help me

Thanks !

More about : problem titanium noise

January 7, 2009 6:29:15 PM

Did you disable onboard sound when using the X-Fi?
January 7, 2009 6:30:08 PM

It's possible that you just got a bad card, or one that is incompatible with the most current drivers. Personally I have not trusted creative products for a while. Razer (when you can find em), Diamond, and ASUS have some good sound cards, now anyway. Another thing may be interference with the speakers.
Related resources
January 7, 2009 8:49:42 PM

what is onboard sound :S?

Yes, maybe i will change it for an Asus. I Hate creative...
Thanks
January 7, 2009 9:02:43 PM

thats certainly a driver problem. What windows are you using? if the older drivers work perfectly dont upgrade them unless u MUST do it, creative is really bad at Drivers.
January 7, 2009 9:08:31 PM

I'm using Windows Vista x64, i have tried all driver version. D version, Web version and beta version. Now i've got beta, and the noise is very low but it sounds... And i ve disable every cool thing of the card... I think i'm going to throw it to the bin (sell it to a friend) and buy an Asus...
January 7, 2009 10:16:56 PM

I bring bad news. Its most likely your MB. In the past Nvidia chip sets timed out to allow for GPU traffic. It created crashes and loud static on many Nvidia based MBs. Now with PCIE sound cards it makes near exactly the sound you speak of. This is a VERY common problem believe it or not. Other then that you should check to make sure your not putting your spdif output above the default. With vista it often conflicts with SB software and creates a his and or distortion.
January 8, 2009 11:15:11 AM

Same mobo as me, and the same issue with Creative sound cards. Nothing you can do on your end, except switch to either a Razer Barracuda or a ASUS Xonar D2/D2X (both of which work fine, so its not a MB issue, its a Creative one).

I say again:
Do NOT buy a Creative sound card with a NVIDIA based mobo.
January 8, 2009 3:45:22 PM

edit: my problem is not sound card related
January 8, 2009 3:57:25 PM

Onboard sound is the sound that comes with the motherboard. If you install a sound card you need to disable it in the BIOS or they will conflict.
January 8, 2009 4:05:25 PM

Jim_L9 said:
Onboard sound is the sound that comes with the motherboard. If you install a sound card you need to disable it in the BIOS or they will conflict.


No they don't; I still have my onboard on with my Barracuda, no isses whatsoever...oh right...Creative...
January 8, 2009 4:11:47 PM

I've seen numerous cases where XP will blue screen with the onboard enabled when a sound card is also installed. This might cause his noise problem, but disabling it is an easy test either way.
January 9, 2011 12:10:43 AM

Have you tried disabling the mic and headphone inputs on the mixer?
January 10, 2011 6:31:21 PM

jst cause u got onboard nabled doesnt mean u will have nmoise, u are outputting sound from the soundcard, all teh processes are down on the soundcard, whether the onbouard is sensitive to inteferences it will have no correlation with a soundcard.
January 10, 2011 7:42:28 PM

MEgamer said:
jst cause u got onboard nabled doesnt mean u will have nmoise, u are outputting sound from the soundcard, all teh processes are down on the soundcard, whether the onbouard is sensitive to inteferences it will have no correlation with a soundcard.


please try to type something easy to read if you actually want to help someone and not just run up your post count.



On topic.

creative has been known to be god awful terrible with drivers. I'd junk it and get something else 99% problem solved.
January 10, 2011 7:45:37 PM

rand_79 said:
please try to type something easy to read if you actually want to help someone and not just run up your post count.



On topic.

creative has been known to be god awful terrible with drivers. I'd junk it and get something else 99% problem solved.



was typing to fassssst
February 7, 2012 3:42:07 AM

I have the same card and I was searching around for a solution..

I FOUND MY SOLUTION and I have NO MORE NOISE.

In the Mixer there is a Microphone FP all I had to do is mute that.. It is the front panel mic plug in port that was causing my crazy noise.

I am so happy :) 
February 7, 2012 11:36:59 AM

This topic has been closed by Mousemonkey
!