Sign in with
Sign up | Sign in
Your question

External usb hd inaccessible after time

Last response: in Storage
Share
March 20, 2010 6:52:46 PM

Heya.

I'm running Windows 7 and am having issues with a Maxtor Basics Desktop 750gb USB HD (ntfs).
First off, i have been using this drive together with my brother, who was accessing it with his macbook pro.


I was able to access files on the drive for a couple of minutes then all of a sudden i wasn't able to access any of them anymore.
I could browse the directories but I wasn't able to open any of the files. I could unplug the drive (both usb and power), wait a few seconds, plug it back in and was able to access the files again (for some time).

So I tried to format the drive. Using the command prompt command > format /X /FS:NTFS F:
Progress stayed at 0% all the time before telling me that it's not able to format.

Then, somehow the Filesystem changed to RAW and I wasn't even able to access the files anymore.

Now I've tried repairing whatever can be repaired using SeaTools Long Generic "test".
Problem is, while scanning and finding errors, the Drive becomes inaccessible again, which causes the test to fail and none of the found bad sectors (?) to be repaired.



Any ideas what's causing this?
Any help would be really appreciated.

I hope you guys can help me :( 
March 21, 2010 9:05:04 AM

Thanks for your reply.

I should have made my intentions more clear, my bad:

The main problem seems to be that I lose all access to the drive after a certain period of time.

My main goal is to format the drive - I have already recovered the files i wanted when I was still able to access the drive - the filesystem was NTFS.

But formatting always fails - seemingly because the drive cannot be accessed after a certain period of time.
Same happens to chkdsk and SeaTools - they seem to work fine for a couple of minutes before they ultimately fail - before any repairing or restoring was done.
March 21, 2010 6:21:53 PM

It sounds a bit like the controller on the inside of the external HD could be going dodgy.

I bought a cheap external HD case and put my own drive in it. Worked fine for a year or so then would start 'disconnecting' from the computer as though the usb cable had been unplugged. Out the drive in another case and it was fine.

Or it could be the usb cable or power brick/cable has an internal break in it. This would also cause weird issues.

I would plug it in then slowly wiggle a bit of the cables one at a time and see if anything happens. Also have you checked the maxtor website for their HD checking tools? That's always a good place to start, and it may give you an error code which you can use for a warranty replacement (well, if it still under warranty that is)
!