Sign in with
Sign up | Sign in
Your question

Detailed gigabit speed issue

Last response: in Networking
Share
April 12, 2009 4:15:04 PM

I have 3 computers networked at my home in which I am trying to improve my network transfer speeds. I have scoured the internet for the last week trying to resolve the issues. I am looking for some help and will try and provide as much background information.

MainPC: EGVA Nvida 680i sli board using onboard Nvidia NIC running Windows XP pro
RAIDserver: Foxconn G31MV-K RTL 8168/8111 pci-e NIC running Windows Server 2008
HTPC: GIGABYTE GA-P35-DS3L RTL 8168/8111 pci-e NIC running Windows XP pro
Swith: D-link gigabit DGS-2205
Using Cat5e cable throughout the network
All NIC drivers have been updated

MainPC: Running 3 Velociraptors in RAID5 with Areca RAID controller - HDtune average speed 220 MB/sec
RAIDserver: Running 8 Samsung drives in RAID6 with Areca RAID controller - HDtune average speed 340 MB/sec
HTPC: 150gb Raptor - HDtune average speed 72 MB/sec

I am most concerned with the speed of file transfers to and from the MainPC and RAIDserver. However, I would like to get the entire network closer to maxing out my gigabit network, which should be close to 120 MB/sec.

Copying files from the RAIDserver to the MainPC, I am averaging about 50MB/sec. Copying files from the MainPC to the RAIDserver, I am averaging about 62MB/sec. Obviously the speed of my harddrives are not the issue. The ethernet cable running from my MainPC to the RAIDserver is only 8 feet. The cable running to my HTPC is probably 75 feet. Speeds to and from the HTPC are about the same.

I have tried enabling jumbo packets on all 3 systems, but have had no luck. It actually slows down the network. The NIC on my MainPC has different MTU settings than the two Realtek NIC's. The options are as follows:

Nvidia NIC: 1500 (standard), 2500, 4500, 9000.
Both Realtek NIC's: disabled (assuming 1500), 2KB, 3KB, 4KB.

All NIC's are set to autonegotiation, though I have tried simply enabling gigabit full duplex. Flow control is on. I have tried enabling and disabling the Qos packet scheduler.

Numerous configurations, cat5e cable swapping, reboots, and other NIC configuration adjustments have not helped. I even used the Nvidia NIC teaming option. Though the speed I am getting is good, I see no reason I should not be able to get closer to 100 or 120MB/sec. This could be an OS, driver, interference or any other issue. I am wondering if I am dropping packets or if the NICs simply won't push higher speeds.

Any help would be appreciated!!!

David



April 13, 2009 2:52:21 AM

Are you copying one very large file (several GBs in size) or a bunch of small files?
April 13, 2009 9:55:58 PM

I have noticed that it does better with a bunch of files, vs one large. The MB/s numbers are for smaller (100mb) chunks of rar files.
April 14, 2009 1:02:01 AM

Transferring large files often provides better performance. When testing a network, I normally copy files both ways to make sure that there are no issues, particularly with switches and server NICs. As a quick test, I copied a 565 MB file on my home network and it takes 10 seconds from and to the server, therefore I know that my LAN works fine. My transfer speeds are somewhat limited by the SATA hard disks.
!