Sign in with
Sign up | Sign in
Your question

8.11 Drivers Released

Last response: in Graphics & Displays
Share
November 13, 2008 3:39:14 AM

New drivers released!


http://ati.amd.com/support/driver.html :bounce: 

More about : drivers released

November 13, 2008 3:54:29 AM

Good find. I can't believe how fast they are releasing these things. Between beta's and normal drivers I'm downloading drivers every two weeks. The 8.11 beta's crashed my system so I'm anxious how these will work out.
November 13, 2008 4:02:47 AM

dammit I just installed 8.10 about a week ago.



EDIT: Just read the release notes, mostly just updates for FarCry 2 and STALKER. Nothing for me here this time.
Related resources
November 13, 2008 4:40:15 AM

wow :na:  that is awsome how fast they do updates at this rate no matter where they go. they will eventually end up with some kick ass drivers
a b \ Driver
November 13, 2008 5:32:19 AM

Nice find thanks :) 
Good i was waiting for FC2 and STALKER CLEAR SKY performance increase :) 
November 13, 2008 5:49:03 AM

Finally.... the hot fix gave me BSOD... this should work.. i hope
November 13, 2008 1:30:23 PM

Nice work ATI. ^yeah, I'm crossing my fingers that this ends my 30min crashing problem but that might be a FC2 patch that is needed.
November 13, 2008 1:44:54 PM

They released a patch to fix these issues :lol:  . The patch didn't do much for me either.. I have a question guys.. How do I get to where my amd overclock utility will work with the new 8.11 drivers as I am doing a comparison to see if performance improved with my 4870 1GB but, if I can't overclock the card then, well the test will be pointless. Thanks for the help guys.
November 13, 2008 1:50:55 PM

guys, you realize its once a month right? way to go ati

but i refuse to update my drivers until rivatuner adds support for them
November 13, 2008 2:14:02 PM

Yeah Rivatuner isn't working either. Some one any one know how to hack around this?
November 13, 2008 2:15:19 PM

eklipz330 said:
guys, you realize its once a month right? way to go ati

but i refuse to update my drivers until rivatuner adds support for them


Version 8.10 CCC included a long-awaited manual fan control feature so I am not sure why you need to wait for rivatuner. Unless you feel the 4850 or 4870 has room for an overclock that CCC cannot handle? I am still letting CCC auto control the fan on my 4850 as I do not see temps much above 80c.
November 13, 2008 2:33:01 PM

Mine goes wayyyy..... past what ccc does "stock voltages exc..". I need to compare drivers but, can't until fix is in place for overclocking either on amd tool or riva tuner, whichever. Thanks again.
a b \ Driver
November 13, 2008 4:24:11 PM

I tested FC2 BENCHMARK TOOL and my FPS was the same but when i played i got 10 FPS increase :) 

And in STALKER well i got few more FPS but still the game isnt very playable for me.
November 13, 2008 4:45:23 PM

Well I will play it later. I was doing what you did with the benchmark tool. It must be different then in game play if that is the case. Odd..
November 14, 2008 12:55:21 AM

I play stalker just fine....with everything turned up too
November 14, 2008 2:57:31 AM

Dang, still get the 30 minute crash. Runs pretty smooth though on one 4870.
a b \ Driver
November 14, 2008 6:01:15 AM

jackieboy said:
I play stalker just fine....with everything turned up too

What is the resolution u are testing ?
I am testing with 1680x1050 resolution DX10 and everything is maxed out and i got a very bad FPS (20)
November 14, 2008 10:27:34 AM

Yeah EPIC FAIL on their part. I still see stuttering in far cry 2 and everything in my machine is high end. I am running the game at 19xx x 1200 and I haven't seen the stuttering stop since I have begun playing the game.... I have the 1GB 4870 and it can run it's core at 870 all day stock voltages exc exc.
a b \ Driver
November 14, 2008 10:53:15 AM

I checked their forums and am seeing complaints about it. So before I consider installing it I'm going to wait a little while and see.
November 14, 2008 11:41:42 AM

Still getting stuttering and 30 minute crashes on far cry 2 huh?

I was hoping these 8.11's would fix that, I'll install them this weekend and see how they do on my system, not getting my hopes up.
November 14, 2008 11:47:24 AM

So I did some 3DMark Vantage test and found that in some areas of the graphics tests, there was a 10% gain so I got all excited and poped open FC2 for testing.

On the old 8.10 drivers with FC2 hotfix I get pretty much 50 fps through out on 1680 x 1050, Ultra high, AA x2 and a low of 43 I think..

On new 8.11 drivers I get 45-48 fps most of the time and occasionally 50 fps. The max that I've got reached 60 but WTH? I got a 10% performance decrease on avg?

The old lag which I get from driving on the cars did not improve. In fact, I started feeling lag when I'm walking normally now.

I don't really like this driver =/
November 15, 2008 3:54:51 AM

I wiped out my OS and reinstalled everything and all my choppy **** is gone now FYI. I think I had reminents of my nvidia card left and it was pissing it off. Bad thing is that there is no way around ccc over clocking limit in sight , for me any way unless some one tells me why my overclock acts funny with these drivers even after flashing the BIOS...
November 15, 2008 3:03:34 PM

truehighroller said:
I wiped out my OS and reinstalled everything and all my choppy **** is gone now FYI. I think I had reminents of my nvidia card left and it was pissing it off. Bad thing is that there is no way around ccc over clocking limit in sight , for me any way unless some one tells me why my overclock acts funny with these drivers even after flashing the BIOS...


well there's a program out there called "Driver Cleaner 3" which helps you clean off all those nvidia files. I wouldn't go though all the trouble of reinstalling my entire OS and program files just to get FC2 to play smooth. I'd rather play something else. There are so many great titles out right now.

I've got Fallout 3 I wanted to try and Left 4 dead that I definitely will get sometime. It's just not worth it.

But for my case, I wouldn't even consider this issue because when I installed Vista x64 Ultimate, I already had my 4870 installed so the first drivers were ATI only. Nvidia drivers couldn't have been the issue.
November 15, 2008 3:15:40 PM

Yeah I had an image of my OS and it had nvidia on it. It wasn't that big of a deal because now I will have a fresh image that doesn't have nvidia on it and the difference in FC2 now is asstonishing . Also I used driver cleaner pro to try to get rid of traces of everyhting and that obviously didn't work apparently the game was confiused as it still seen nvidia some where because now everyhting is smooth as butter now I just need to figure out how to get around this driver overclocking,,,,,,, retricted crap,,,,,, I am dealing with.
November 15, 2008 3:39:29 PM

well I'll give it ago with DC Pro v1.5 anyways.. I'll report back what happens.
November 15, 2008 3:49:25 PM

talk about good games anyone played dead space, best game on the market
November 15, 2008 4:25:49 PM

ok I've just tried driver cleaner.net and it didn't work. The program froze as I tried to remove any nvidia drivers. I rebooted the comp and tried FC2 again and still it stutters.
November 16, 2008 12:53:02 AM

driver cleaner pro does that to me with my ati driver removals.. I have to end the process to get it to come back up.
November 17, 2008 1:07:09 AM

Maziar said:
What is the resolution u are testing ?
I am testing with 1680x1050 resolution DX10 and everything is maxed out and i got a very bad FPS (20)






I am using the same resolution as you are.....I don't know what my actual frames per second are but it plays the game just fine with max settings
November 20, 2008 4:15:36 AM

Well I just updated my drivers, and now my vga keeps restarting when i play any games. The ATI software keeps recovering it though. Anybody know if this is a driver issue, should I uninstall and use the ones on the disc when I got it?
November 20, 2008 5:35:44 AM

mark $ said:
Well I just updated my drivers, and now my vga keeps restarting when i play any games. The ATI software keeps recovering it though. Anybody know if this is a driver issue, should I uninstall and use the ones on the disc when I got it?


The drivers on your CD are really out of date though. Try uninstalling all drivers in safe mode and then reinstalling the drivers. You can also try to turn off VPU Recover to see if you can gain some stability since VPU recovery feature is known to crash games.
a b \ Driver
November 20, 2008 7:52:16 AM

Uninstall the driver from Control Panel then Download Driver Sweeper and install it
http://www.guru3d.com/category/driversweeper/

Go to safe mode and use driver sweeper and clean what its left for a clean uninstall ;) 
and then install the new driver :) 
November 20, 2008 1:52:32 PM

ok the 8.11's did not fix the choppyness for me either. Disabling AA gets rid of it but even with 4x enabled the fps never drops below 40 so what is going on?

I always use driver sweeper to clean. so that solution does not work for me...driver cleaner does not work on my system, is it compatible with vista 64?
a b \ Driver
November 20, 2008 6:50:49 PM

Yes it is i have used it and its great :) 
November 21, 2008 12:22:23 AM

yes it is except Driver Cleaner.net froze when I was trying to clean it on vista 64bit
November 21, 2008 2:43:55 AM

I posted another thread about this but does anyone know whether they will address the issue with HDMI sound being disabled if the TV is turned off or the input changed? I know it hsa something to do with my TV not sending the EEID when the input is not being used but that's about it. I'm a noob, what can I say...
November 21, 2008 1:03:41 PM

murdoc said:
yes it is except Driver Cleaner.net froze when I was trying to clean it on vista 64bit


That's what it does to me... I've reinstalled it so many times and it just freezes while cleaning. So I switched to driver sweeper and it seems to work nicely.
November 21, 2008 7:45:26 PM

BlakHart said:
That's what it does to me... I've reinstalled it so many times and it just freezes while cleaning. So I switched to driver sweeper and it seems to work nicely.


Hmm.. ok I guess I'll give that program a go and see what happens... but given that I didn't install any nvidia video cards when I've installed vista 64bit I don't see why I would have this problem.
November 21, 2008 7:59:49 PM

Driver cleaner Ive heard, removes too much, and hasnt been updated in quite awhile
a b \ Driver
November 22, 2008 7:22:17 AM

Yeah i wanted to DL it from GURU3D and look here:
http://downloads.guru3d.com/download.php?det=745
Update: This software was removed at the request of the publisher. A newer version of their software is still available yet shareware, to be found at the author's website.

As an alternative we'd like to recommend you Driver Sweeper (completely free), please click here.
November 22, 2008 6:38:01 PM

Ok, I've just tried Driver Sweeper and it's worked pretty well. I'm glad to find that it's free and there were no problems on Vista 64bit. I'm going to give FC2 a try now to see what happens.

**Edit: I've tried and well.. gameplay improved but overall FPS dropped (Average now at 40 instead of 50). Driving got a bit more smoother after removal of Nvidia stuff but there's still a slight bit of jittering. **
November 24, 2008 9:50:15 AM

It still does it on my PC too...just not as bad it seems like, must be a driver issue, or something that needs a patch from ubisoft. If I play without AA enabled it goes away. But I hate doing that when the frames are so solid lol. I'll just wait...
November 24, 2008 11:46:33 AM

ooo maybe that's the problem. I didn't try turning off AA. I think this needs to be fixed by ubisoft and I hope it does.
November 24, 2008 3:56:52 PM

murdoc said:
Ok, I've just tried Driver Sweeper and it's worked pretty well. I'm glad to find that it's free and there were no problems on Vista 64bit. I'm going to give FC2 a try now to see what happens.

**Edit: I've tried and well.. gameplay improved but overall FPS dropped (Average now at 40 instead of 50). Driving got a bit more smoother after removal of Nvidia stuff but there's still a slight bit of jittering. **



I was caught up messing around with all of the hotfixes from ATI...intalling and uninstalling like crazy. Thought it was a good idea to use DriverSweeper to make sure everything was cleaned out. It crashed in the middle of the process and it screwed up my registry. I couldn't access anything from one of my HDDs after that. Be warned...it can be evil.
November 24, 2008 4:00:34 PM

And about 8.11, it still didn't fix the 0x116 atikmdag.sys BSOD, bah.
!