Sign in with
Sign up | Sign in
Your question
Solved

Bootible SATA duplication not booting

Last response: in Storage
Share
March 24, 2010 9:38:33 PM

Have an HP Pailion a1648x with XP Media Center 2005. The native drive is a Samsung 300 Gb (270 Gb formatted) SATA. As the drive was getting a bit full, and storage costs were coming down, I decided to get a larger drive.

I purchased a Hitatchi Deskstar 1 Tb SATA drive. I partitioned the drive with a large NTFS primary partition and a small FAT recovery partition (like the OEM drive).

After partitioning and formatting, I used Norton Ghost 15 to duplicate both partitions. Then I shut down, moved the new drive to be the only drive, confirmed the boot config, and booted. The machine started to boot. I got the Windows splash screen, then the light blue screen with the darker lower and upper bars that usually comes up briefly before the desktop appears. It also has a smaller logo on it. Then...it froze. Nothing. No drive activity (near none), no screen action, nothing. No change with reboots.

I did the same thing with Clonezilla, which operates outside Windows. No change. Exact same result.

What am I missing? I have verified that the new drive contains the contents of the old drive. I even copied it with the comparison features on. What gives?
a b G Storage
March 25, 2010 12:18:48 PM

Is the bios recognizing the full capacity of the disk?
March 29, 2010 11:13:42 AM

Yes, it is.

I have seen drivers mentioned. However, I have had no driver issues and I am not sure any drivers are needed. As I said, the disk proceeds partially through the boot process and hangs despite trying two different software packages.
Related resources

Best solution

a c 126 G Storage
March 29, 2010 1:54:36 PM
Share

Do not create the partitions yourself on the new drive; do a raw byte-by-byte copy of the old drive to the new one.

You can best use an Ubuntu livecd for this task. Using the dd command you can transfer the array:

sudo dd if=/dev/sourcedisk of=/dev/destinationdisk bs=1M

the sourcedisk is the older 300GB samsung, the destinationdisk is the 1TB hitachi. To check the names of your drives try this command:

dmesg | grep -i GiB
or:
dmesg | grep sd

That should list your drive names (/dev/sda, /dev/sdb) and their capacities so you know which disk is which.

Warning: do not make mistakes with dd commands; any mistake may destroy your data!
April 5, 2010 7:45:05 PM

Sounds like a plan. I have an Ubuntu system I might be able to cable both of these disks up to as well.

Let me me try either cabling the disks up to the Ubuntu box, or whipping up a fresh CD and working with that. I'll report back...
April 8, 2010 5:55:14 AM

Good news! The dd worked! Another reason to NOT use Windows.

The (not so) bad news: It left me with a 1Tb disk that had a clone of a 300Gb disk on it. So, I had to grab Partition Magic, move the "D:" recovery partition down to the end of the disk as "J:" (I actually created another FAT32 partition and XCOPYied it because I could not get it to work like I wanted), delete the existing "D:", merge all the free area with "C:", and then rename "J:" to "D:". The J: or D: was verified for size and behavior. Plus, I have backups and a spare on the original drive.

The only niggling issues are that (1) I currently find that I have no J: drive letter, which used to be one of the virtual drives for my card reader. Perhaps it will return if a card or thumb drive is used in that slot. The other is (2) the nice pretty arrangement of drives, printers and such on the "My Computer" display seems to be completely linear now. A very mild issue.

I have a 500Gb EIDE to put in an older machine. Think I'll slide that into a USB holder and use the Ubuntu scheme to do that one pretty soon. The native disk on that system is 35Gb and full to the gills.
April 8, 2010 5:56:55 AM

Best answer selected by sekinstl.
a c 126 G Storage
April 8, 2010 3:31:50 PM

In the Disk Management screen in Windows (right click My Computer -> Manage -> Disk Management) allows you to set drive letters for just about anything; you just can't change the drive letter of the in-use system drive.
April 10, 2010 5:47:40 AM

True enough.

Regardless, the J: reappeared upon the first insert of a "thumb" drive into the first USB port.

I managed the 500Gb install on the other machine without incident. Wisely, Dell put their 'recovery' partition at the front of the drive, allowing me to do everything without having to hopscotch the partitions over one another. Then, all I had to do was extend the NTFS partition out to the remaining space.

All is well, and I have much more space. :D 
!