No sound on since burner firmware update failure

I just purchased an LG MULTI Blu-Ray internal drive WH08LS20 which I mounted in an external enclosure. It worked great for 2 days. I got a pop up saying I needed to install a firmware update, so I clicked on it. It did not fully install. Shortly after this the drive stopped working properly and my internal DVD drive stopped working as well. On top of all this I have no sound, no CD, DVD, System Sounds, nothing. The little graphic meters rise and fall but there is no sound. I have tried several players as well. The headphone plug doesn't work either. I have tried the speakers and they work apart from the computer, so I don't know what the problem is.
Has anyone else encountered anything like this?
My computer is an Acer AX1300-U1802A running Windows & Home Premium
1 answer Last reply
More about sound burner firmware update failure
  1. updating an external drive is tricky and fails often!
Ask a new question

Read More

DVD Writers Firmware Storage