Sign in with
Sign up | Sign in
Your question

4870 in CrossFire

Last response: in Graphics & Displays
Share
November 20, 2008 6:43:03 AM

Hi everyone.

Just built myself a new computer a couple weeks ago, and couldn't be happier. Well...actually, yes I could be. See, I have 2 4870s, but for the time I've had my computer, I didn't have a crossfire bridge. Just came in today, and I installed them, but to no avail; no performance was increased. I used fraps to test out my main 2 games that I play, which are oblivion (the one I play the most often, by far) and fallout 3, and then net_graph in CS:Source. In every of those three games, I just about get a 60 fps frame rate (everything completely maxed out, both on the card, and on the game) on a measly 1280x1024 (the max my monitor supports, i have a 19"); a little more or less depending on the environment I'm in. THat's with 1 4870. That's actually pretty good, but I wanted to actually get into the 70s and 80s. I know it's possible, because I've seen it, both on forums, and with friends running similar rigs. However, when I got my bridges in earlier today and then installed them...nothing happened. I checked enable crossfire, but nothing happened, no performance increase. I then followed the advice from a site; I uninstalled the drivers completely and used drive cleaner pro to really clean it out, then I put one 4870 in and installed the drivers for that (the latest 8.11). I shut down the computer and then put in the second card WITHOUT THE BRIDGE and then installed the drivers for that, then shut it down again and put the bridges in and then turned on crossfire, but then same thing. I get the same exact fps every time. No improvements whatsoever. I then tested a game (oblivion, which is the game that I built my system on) with crossfire disabled, noted the frame rate, then did the same thing in the same place with crossfire enabled, and I got the same exact fps. I must be doing SOMETHING wrong, because I know I should be seeing SOME kind of improvement. I mean, when I look at configure and diagnostics, it's just a blank page. Can anyone help me? Here's what I'm running if it helps;

Windows Vista Ultimate 64-bit, Intel Q9550 @ 3.2 GHz, 8GB mushkin DDR3 1600 (4x2gb), Asus Rampage Extreme, and of course, 2 ATi 4870 GPUs.

If you need to know more, just go ahead and tell me what else you need to know.

More about : 4870 crossfire

November 20, 2008 6:53:51 AM

I just plugged in both my cards with the bridge, installed the driver and it worked fine. go to device manager and see if both cards are installed properly.

With that resolution, your not even stressing one card. You will see dramatic increase if you increase your resolution especially res beyond 1900x1200.
November 20, 2008 6:55:53 AM

Well, if your fps is exactly 60 or lower always, then you likely have vsync enabled. This limits you framerate to the the refresh rate of the monitor. Go into ccc and turn it off.
Related resources
November 20, 2008 7:00:39 AM

@ZeCow: I know. I'm getting a new HDTV that will serve as my monitor in a month's time. I just want to get it working on my current monitor first before I move to the really hi-res.

@orangegator: Ah, I see. Yes, I DO turn on v-sync. I didn't know that that would limit it. I'll turn it off right away and see if it makes a difference. Thank you very much

A big thank you to both of you for your replies
November 20, 2008 7:11:57 AM

i turned off v-sync, and when I did a stress test in counter strike...holy hell that was a humongous increase in fps! and that was with crossfire disabled. I went from 59 fps average, to 189! then crossfire, and it went to 260 average. that is an incredible increase. However, when I did my fraps-oblivion test, i saw absolutely no increase...at all. could it just be fraps or could it be something different? I remember my friend saying that your fps will increase in crossfire, so I know it'll work but (i've seen it, not a lie)...it hasn't happened for me yet. When I asked him, he told me to do what I said I did, which was uninstall then reinstall one by one. that didn't work, and turning off v-sync didn't work either. is there a fix I should maybe do? or should I just kinda give up on that one? (i'd rather not)
November 20, 2008 7:22:57 AM

If you are using 8.11, at the trayicon, right click and theres an option to display crossfire logo. The logo will appear if the app uses crossfire. Check and see.
November 20, 2008 7:31:35 AM

Ah, okay, I see. Yes, thank you. oblivion is using crossfire. and now i have a way to see if others do too. I saw what was wrong though. In Oblivion, i almost always use 3rd person view. but the instant I switched to 1st person, my fps shot out the roof.

thank you guys for your help, I really appreciate it.
!