Sign in with
Sign up | Sign in
Your question

Raid 0 configuration using NVRAID stopped working after crash

Last response: in Storage
Share
March 28, 2010 6:22:30 PM

I have the following set up:

- ASUS A8N-SLI Premium motherboard (http://www.asus.com/product.aspx?P_ID=nbulqxniNmzf0mH1&...)
- Two 250 GB Hitachi Deskstar disks in a RAID 0 (stripe) configuration using a nForce4 raid controller (build in the motherboard)
- This set up has been working ok over the last 4 years

Yesterday I was browsing the internet when my PC suddenly stopped working and automatically rebooted itself. After the reboot the only message that would appear on the screen was "disk boot failure". I rebooted the PC over and over again but the message would not disappear. I spend most of the rest of the day to find out how I could fix it but so far without luck.

In the past the computer always gave me an option during startup to enter the NVRaid BIOS Utiltity (using the F10 key). This option was no longer available during startup so one of the things I checked were the BIOS settings. They were all configured correctly but the NVRAID raid controller was unable to see my disks. I have two 250 GB Hitachi Deskstar harddisks in a RAID 0 configuration. This is what I did so far:

- I checked the power supply of the disks with a voltmeter, this was ok. The Hitachi Deskstar disks have two different sockets for the power supply and I tried both sockets with different power cables. This did not help to make the disks visible in the BIOS.

- I updated (flashed) the BIOS of the PC to the latest available BIOS version, this did not help either.

- I removed the battery on the motherboard to reset the BIOS settings, this wiped out all BIOS settings but did not help to make the disks visible.

- I checked the SATA cables and connected the disks to SATA port 3 and 4 instead of port 1 and 2, in which they had worked ok for about 4 years. Still I was not able to see the disks in the BIOS.

- My motherboard is an ASUS A8N-SLI Premium and has two raid controllers on it. The one that I was using succesfully for about 4 years was the nForce4 raid controller but it also has a Silicon Image 3114R RAID-controller which was disabled in the BIOS. I disabled the nForce4 controller and enabled the SI controller. I also swithced the SATA cables from the black SATA sockets (nForce4) to the red SATA sockets (Silicon Image) on the motherboard. Now the disks showed up in the BIOS under the Silicon Image controller settings ! So my hope now is that the disks are ok but that the problem is in the nForce4 raid controller. Unfortunately I could not read the disks with the SI controller because the SI raid 0 is not compatible with nForce4 raid 0. The only option I had was to set up a new raid 0 config but that would wipe all the data from the disk so I did not do that.

My main problem is that I have a lot of important data on those disks and without a working NVRAID controller I will not be able to recover that data. (I know I should never have used a raid 0 config without a proper backup :)  but there are more things in life that we do while we know we shouldn't :)  )

I can't think of any other options right now without taking the risk of losing the data. My last option that I can think of is to find a second hand motherboard with the same nForce4 raid controller to check if that one is able to read the disks.

Did anybody have this problem before ? Is there anybody that knows why my disks don't show in the BIOS anymore and why the NVRaid BIOS Utiltity has disapeared from the boot screen ? Can anybody give me a good suggestion how I can recover the data on my disks ?

April 1, 2010 7:45:46 PM

Problem solved. Tonight I replaced the motherboard with an identical second hand one and everything worked again straight away. Apparently the NVRAID controller was no longer working correctly. Fortunately both disks were still ok. :)  :)  :) 

I only wonder why the controller died. I suspect that the windows 7 power settings that turn the disks on and off have something to do with it but I have no idea if that actually is the case or not. My theory is that switching the harddisks on and off caused a component somewhere to break, but I can't prove that so it's just a wild guess.

The whole idea behind a raid configuration is pretty sophisticated but it all falls apart when the raid controller itself dies. It turns out that every raid controller uses it's own format on the disk so if you don't have an identical raid controller you will never be able to recover any raid configuration ! This experience certainly made me a lot more carefull in using RAID configs.
!