The format did not complete successfully

I bought a Western Digital Caviar Black WD1001FALS 32MB 1TB Hard Drive 7200 RPM 32MB and I keep getting the "the format did not complete successfully" error. I thought it was quick format so I just did a full format which took like 1hour+ and got the same error right at the end.

Any ideas on how to fix or is the drive faulty?
2 answers Last reply
More about format complete successfully
  1. Ok well for some reason it worked with the format manager when installing a new operating system. Although windows 7 took about 4hours to install, no exageration here. Even the little things like setting the time took about 1minutes to get the next step.

    Is there any hard drive diagnostic tool I could use to make sure the drive is running properly? THanks.
  2. Please check for PIO issues (google on it and you get 300 billion hits or so).
    It could be that either cable issues or other issues are causing errors; forcing the drive to fall back to PIO mode.

    You didn't say whetehr this is SATA or PATA; but both can be hit by a PIO issue.
Ask a new question

Read More

Hard Drives Western Digital Format Storage