Sign in with
Sign up | Sign in
Your question

Windows 7 64-bit does not show all of my ram!

Last response: in Memory
Share
February 25, 2009 9:01:55 PM

Windows 7 64-bit when I first installed it showed only 3GB of ram. I thought it was a mistake since I had 4GB so I got CPU-Z and restarted it and it showed 4GB of ram. :heink:  I restarted it and it showed 4GB of ram and I thought it was all fine and the 3GB of ram happens from time to time but now when I checked my RAM it showed 3GB so I went into CPU-Z and it said around 3GB so I tried BIOS and it said around 3GB. Could this be faulty ram? :fou: 

More about : windows bit show ram

February 25, 2009 9:10:07 PM

if even the BIOS says 3GB, then something is wrong with the ram. check to make sure all the sticks are fully seated.
February 25, 2009 9:18:49 PM

It is your motherboard most likely. You need to enable PAE (Physical Address Extension) to get the motherboard to recognize anything over 3GB of memory. 32bit OSes recognizes only the first 3GB of memory. Consequently, most of the MoBo's do not have PAE enabled by default even if you plan on using a 64bit OS.
Related resources
February 25, 2009 9:25:32 PM

But this is for 64-bit not 32-bit.
a b } Memory
a b $ Windows 7
a b à CPUs
February 25, 2009 9:26:54 PM

Mind listing full specs? You RAM could be reserved by hardware(IGP,etc) also btw.
February 25, 2009 9:29:35 PM

Intel Q6600
Nvidia 8800GT
4GB of RAM
GIGABYTE GA-965P-DS3 LGA 775 Intel P965 Express ATX Intel Motherboard
February 25, 2009 10:05:58 PM

I agree with Nik. Looks more like a Ram Issue, have you tried a different Ram or try changing the ram positions.
February 26, 2009 12:19:08 AM

I had this same problem. I checked around and it was suggested to enable memory holes in the bios, then the full amount of memory showed up. I did not research why this worked, but I can only say it did.
February 26, 2009 12:47:48 AM

Never mind people! You can close this thread now. It was caused by a faulty piece of RAM and when I tried to remove it and put it back in I was stuck at the boot-up menu so I tried removing various sticks of ram and picked one out and started the computer up and now it is good.
!