Sign in with
Sign up | Sign in
Your question
Solved

Windows XP doesn't see the SATA Drive (windows setup)

Last response: in Storage
Share
April 2, 2010 1:47:10 AM

I have an older system here with two SATA ports, never been used. Its always used IDE.

Today, I put in a SATA drive and want to install Windows on it. The Windows XP setup disc won't detect the SATA drive. It only detects the IDE drive.

So, I disconnected the IDE drive's power, tried again and it detects no drives.

During bootup, it shows the SATA drive during POST and I can enter a RAID utility, but I can't edit anything because there's only the one drive.

In the BIOS, it also shows, but it's showing as SCSI-0 under HD bootup priority for some reason.

What can I do to make Windows XP setup see the drive?
April 2, 2010 3:01:10 AM

An update: I found a SATA RAID driver on the motherboard manufacturer website. I grabbed it and put it on a floppy.

I ran Windows XP setup and loaded the driver and it saw the drive during setup.

Now I have a new problem, It won't install on that drive. It says once I've partitioned the drive, that it can't install because it's not an XP compatible partition. What does that mean exactly?

Is it a size issue? The drive is a 320GB drive (the old IDE was a 40GB drive). The Windows setup disc is an XP Pro setup disc.
April 2, 2010 3:21:51 AM

Exactly what happens when you get to the screen where XP shows your drive? At that point you should be able to delete all the partitions on the drive and create a new one, format it and install.

If you can still boot from the old IDE drive, you can install the SATA drivers and partion it from there.
Related resources
April 2, 2010 3:52:57 AM

I delete the partition, create a new one. It says C: blah blah blah [raw], I hit enter to install Windows and it says it's not an Windows XP Compatible partition and to go back and create one.

I tried using Gparted to create a partition and set it to format as NTFS. Went back, selected it to install Windows XP on and it gives me the same compilable partition message.

Edit: Am I running into the pre-service pack 1 137 GB partition limit here? (I just thought of this)
April 2, 2010 4:07:30 AM

What version of XP are you using? SP0, SP1, SP2 or SP3? If I remember SP0 can only use 137GB. You have 2 options in that case.

First. Make a small partion. Say 100GB. Install XP. Install service packs. Use partitioning software to change the size.

Second. Download SP3 and slipstream it into your XP install disc. Here is a site that can help you do it.

http://filesharingtalk.com/vb3/f-guides-and-tutorials-6...

You can put your SATA and network drivers in too.
April 2, 2010 4:24:59 AM

Well, it is SP0, in other words no service packs. However, when I went to make it a smaller partition of any size smaller than 137GB, it still says not an XP compatible partition.

I just don't get it.

I'm guessing it has something to do with the fact I'm using SATA RAID drivers from a floppy to even let XP see the drive during setup?

I'm at a loss as to what to do at the moment.

Best solution

April 2, 2010 5:55:50 AM
Share

Googled. Seems this problem is caused by other drives on the system. Remove all drives but the CD. Remove any card readers. Anything connected to USB. Get it down to bare bones for install. Every fix was removing another drive or device.

If that doesn't work then get a SATA DVD drive and try it so everything is on the SATA ports.
April 2, 2010 6:09:47 AM

That did it, unplugged everything, just the drive + CD drive and voila it's installing Windows XP as we speak.

Really appreciate the help!
April 2, 2010 6:09:59 AM

Best answer selected by templetonpeck.
!