Sign in with
Sign up | Sign in
Your question

Weird problems with radeon x1950 xtx

Last response: in Graphics & Displays
Share
November 26, 2008 7:54:45 PM

i recently bought a radeon x1950 xtx (yeah, dont tell me its old, i figured that i will not play dx10 games, so this suites me well).

first thing: it was a used card, came without any manual, cables, etc.
was told it was used for a few hours, dunno.
look exactly like this: http://techreport.com/r.x/radeon-x1950xtx/cards2.jpg
so no signs of what second-party manufacturer produced it (catalyst control center says "Graphics Card Manufacturer Built by ATI", and gpu-z at subvendor line says ATI(1002)"

figured it came without everything (just the card itself), so without the 6-pin power cable, so i got one from a firend but he`s cable looks like this:

_=_
|000|
|0[]0|

where [] means that pin is not connected, but i checked the card and that pin on the card is actually connected to the pcb.

also note its a Y-cable.

ok, i install the card, and since i have no free regular power cable, i had to use 2 splitter so in the end i had cable all over my case.

no problems, started the machine, removed previous (x550) drivers, installed latest (8.11 - 11/12/2008) drivers, everything`s ok.

i start Elder Scrolls Oblivion, graphics flawless at max settings, and after few seconds at character screen, green boxes and some other smaller glitches appear on the screen, screen freezes up and after a few minutes, it resets the screen.
sometimes it goes full black screen too.

same thing happens under linux with latest drivers over there, it freezes after 20-30 seconds if i run globs(http://globs.sourceforge.net/) `s smoke demo.

ATITool freezes the card up after a few seconds.

it is not a temperature problem, because i set the temperature with atitool to be 55 celsius and it still freezes.

could this be of the newest catalyst drivers?
also note that everything else works fine, no glitches in windows nor linux

please dont tell me my card is fried :( 

any help is appreciated
November 26, 2008 8:28:03 PM

If it can be done, try to slow down the card with ATITools and see if the issue still occurs.
November 26, 2008 9:02:10 PM

What's your power supply?
Related resources
Can't find your answer ? Ask !
November 26, 2008 9:23:12 PM

What Power Supply are you using? Chances are your card isn't getting enough power and that's why you're having these problems.
November 26, 2008 10:07:24 PM

it is a Powerlink 550W - dont know if it falls into the "noname" category, sidenote it has 3 fan on the sides.

aside from the radeon card, i the machine has:
-core2 e6600
-audigy sound card in one pci slot
-realtek Lan card in the other
-a front drive sound blaster 1.5 rack (http://www.hardwarezone.com/img/data/articles/2000/169/... - left one)
-cd-rw - dvd-rom combo drive
-dvd-rw drive
-floppy
-2 hdds: a 180 and a 150 gb sata2 WD caviar
-4 case fans (cheap ones)
-2x corsair dominator
-motherboard is d975xbx

nothing is overclocked
February 16, 2009 4:39:35 PM

a little update:

i bought a new Corsair 750W power supply, no change, windows still creshes.

reinstalled both linux and windows, still no change.

but here comes the tricky part:

borrowed my friends Gigabyte GeForce 9600 GT (which is PCI-E 2.0, and i think my motherboard is only PCI-E 1.0, but i figured it will run anyway), installed it, removed the ati drivers, installed the nvidia drivers, and everything worked perfectly.

atitool ran for a minute, no freeze, no artifacts after ~10 seconds, and Oblivion ran completely smooth for 20 minutes (was flying around the capital city with cheat, everything on max, no HDR or bloom, anti aliasing at 8x)

and one more thing:
the x1950 xtx is perfectly ok, because i tested it at my same friend, and it ran MoH Airborne, GTA 4 and 3dmark without any lockup.

so it seems that every single part of my pc works perfectly, but when i put them together, something goes wrong.

i even tried with removing both the creative card and the lan card and disabling the on board firewire, lan and audio and no change.

btw a question about the bios: what is the pci express test compliance pattern?
should i enable it?
February 18, 2009 8:29:11 PM

another update:

i installed vista, and soon even before installing chipset or radeon drivers, glitches appeared on screen, in catalyst control center, in the preview window the models and the textures were messed up - although it was visible what should be there.
running oblivion crashed in the main menu.

btw i had only directx 9.0c 08 aug version (thoughts it wasnt needed for me to install the dx 10)

any help would be appreciated, im getting close to turn insane after months of going nowhere with this card
February 18, 2009 10:28:33 PM

Quote:
btw a question about the bios: what is the pci express test compliance pattern?
should i enable it?

What happens if you enable it?
February 18, 2009 11:51:49 PM

GhislainG said:
Quote:
btw a question about the bios: what is the pci express test compliance pattern?
should i enable it?

What happens if you enable it?

nothing that i would notice.
i didnt change it whan i swapped trough the x550, 9600 gt and the x1950 xtx, and of the three , only the first 2 worked
February 19, 2009 1:16:16 AM

Have you contacted Intel? You can't be the only one who has that compatibility problem.
February 19, 2009 6:42:53 AM

support is discontinued for this porduct, but available for the d975xbx2 :cry: 
February 19, 2009 11:18:19 AM

It looks like the only option is to either get a compatible video card or get a new motherboard that is known to run that x1950 xtx.
February 26, 2009 9:02:46 AM

I am having this same issue, I have a Radeon x1950 pro and after I play burnout paradise for a few minutes I start getting artifacts and the gfx card resets, I am running an antec earthwatts 550w PSU.
February 26, 2009 2:37:11 PM

I have a few 1950 Pro and they don't have to get that warm to get artifacts. Check it with ATITool (let the test run for long enough to get the card warm) and set it at a frequencies that will not cause artifacts or overheat issues. It should then work fine in games as long as you don't have a profile to overclock it when gaming.
October 18, 2009 10:09:56 PM

I have a Radeon x1950 and it worked great on my machine for a few years. A couple of months ago it starting getting the same glitchs but if I restarted it a few times it would work. Now it is so bad that no matter what I do it gives me the funky characters and some blur marks. Every time I had an update from windows it got worse. I think it has something to do with the op system for this card.
October 18, 2009 11:31:41 PM

It's defective or the fan is clogged with dust. If the fan is clean and the card is under warranty, RMA it. If not, then upgrade to a faster card like the 4770.
!