Sign in with
Sign up | Sign in
Your question

Trouble with new drive + Win 7

Tags:
  • Hard Drives
  • Storage
Last response: in Storage
Share
April 6, 2010 9:03:05 PM

I bought an Intel X25-M G2 80 GB drive today. Thought I'd do a full reinstall and upgrade to Win 7. Prior to installing I turned on AHCI and native mode for the driver. Also plugged in the drive in the first SATA port and the other drives in ports 2,3.. etc.

The problem is that when I try to pick the SSD to install on it says that Windows cannot install with error message 0x80300001. I guess this could have something to do with the ICH10R controller. Tried using the drivers on the motherboard dvd as well as some I found on the net but still got the same error msg in the installer.

My motherboard is a Gigabyte GA-EX58-UD3R.

I've tried reburning the Win 7 ISO (a legal copy!) at a lower speed but still no luck. Guess the ISO could be corrupt. Should I download a pirated copy and change the serial?

Any other suggestions? I thought Win 7 should work without screwing around with any drivers but maybe I was mistaken.

More about : trouble drive win

April 6, 2010 10:09:03 PM

Make sure the drive is the first boot device. To be sure disconnect all drives and USB card readers. Just connect the drive and the DVD.

If that doesn't work you probably need to install RAID drivers during install.

These are usually the two causes.
April 6, 2010 10:16:00 PM

Here is something I found on another forum about loading drivers in Win7.

1.Insert the install DVD
2.Boot into the setup process
3.Get to the point where you need to select a partition and click Load Driver
4.Insert driver DVD
5.Locate the storage driver, in my case the AMD AHCI Compatible RAID Controller
6.Notice the message "Windows cannot be installed on this disk. (Show details)" at the bottom
7.Insert the install DVD back into the drive
8.Expand the advanced drive options
9.Create a New partition consuming some amount of space, in my case all of it
10.Windows says it had to do some funky stuff, click OK
11.Notice that there is a 200MB system partition and a new primary partition
April 7, 2010 8:23:02 AM

Thanks for your help. I've resolved the issue. The ISO was corrupt. Downloaded a pirated version and used my legal serial (which is ok according to MS) and suddenly there are no driver issues at all. :) 
!