Sign in with
Sign up | Sign in
Your question

P5Q-E can't get D-Link wireless card driver to load

Last response: in Motherboards
Share
March 4, 2009 1:59:25 AM

Hello,
I encountered a strange problem on a friend's computer today.

He upgraded his old rig AMD socket 939 rig to a new Asus P5Q-E mobo and an Intel Core 2 Quad Processor Q9400. The first piece of extra hardware he added after a clean install of Windows XP pro (32 bit) was his old D-Link DWL-AG530 PCI wireless card. He let windows pick the driver and it selected version 1.10, which is the correct version for his vintage release of hardware.

The driver install started OK but the computer ended up freezing part way through. Upon reboot the card showed up in the device manager with a yellow exclaimation mark beside it. "Properties" indicted that the driver did not load (error code 39). Unistalling and reinstalling the device did not help. The same situation happened.

I took the card and installed it in an old Asus A8N32SLI rig. The install was quick and the card worked perfectly.

My friend is not happy with the old D-Link card situation and is off to purchase a new card tomorrow. I will let you know if his issue goes away. But in the meantime I am interested in any thoughts you might have or if you have seen this kind of problem before.

Thanks
March 4, 2009 12:46:02 PM

I would assume you updated to SP3 on the OS. other than that the driver my not work with the Interrupt Request of the New MB. the old driver may request resources that Windows no longer allows. multitude of possibilities with older drivers, letting windows pick the driver from the i386 file is not a good idea as that file is as old as the OS. So getting the 4.0 ver. of the driver installer would be a better Idea.

anywho I think we are on the same page now, as I could go on here.
March 4, 2009 1:59:12 PM

Thanks AtaliaA1,

I tried getting the card going with a pre-SP1 version of XP pro and again with SP3 applied. Besides letting Windows pick the driver, I also downloaded from dlink.com and specified the driver manually.

I did not find a 4.0 version of the driver. The dlink download site I checked had the 1.10 version for older hardware and 3.20 for newer revision hardware. Although the card was an older revision I did try the newest 3.20 driver. The rig would lock up during windows startup. I had to fire up into safe mode and remove the 3.20 driver.

The interrupt request is an interesting point. Although no resource conflicts were shown, I should try moving the card to a different PCI slot.

Thanks
!