Sign in with
Sign up | Sign in
Your question

Can't read an old Hard Drive

Last response: in Storage
Share
April 9, 2010 12:59:43 AM

I have dismantled a non-working Compaq Contura laptop and am trying to read what is on the Seagate st9144a 128 mb hard drive that I took out of it. It has a 44-pin interface. I ordered an external enclosure with a 44-pin USB 2.0 to IDE 2.5" interface, but it doesn't work. I am able to plug the interface in, but the enclosure is too small to accommodate the HD. I am getting a "not accessible -- the request cold not be performed because of an I/O device error". This doesn't surprise me, as I suspect the HD is a FAT device on a legacy Windows OS and I am trying to read it with my windows Vista computer.. I am wondering what I might do such that I might read this device.

More about : read hard drive

a c 342 G Storage
April 10, 2010 3:46:25 AM

I suspect strongly that the drive may be so old it does not communicate its setup parameters directly to the BIOS when requested by the usual "Automatic" detection system. You may have to do this the old way - manually enter the drive parameters. For starters, here is the Seagate setup manual:

http://www.seagate.com/staticfiles/support/disc/iguides...

See page 8 (it says 6 at the top) to find those parameters: 980 Cylinders, 15 Heads, 17 Sectors per Track.

Obviously this is an IDE drive. To do this you should mount the unit inside your machine at least temporarily to get stuff copied off of it. Now, that's not quite straightforward because this is not your regular 3½" 40-pin IDE drive, as you already know. You will need an adapter like this from the egg:

http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Take special note of the comments by several users that they had to adapt the adapter (odd!) by breaking off the correct pin on its 40-pin input side so the standard IDE cable (with one pin hole blocked) would fit on. Avoid the error one user made by breaking off the wrong pin - pay attention to the comments about how to get its direction set so you clip the correct pin. And don't forget to connect a 4-pin Molex power supply connector to the adapter, too.

With that you can mount and connect the drive in your machine. Now, any IDE device has to have its jumpers set correctly, and that depends on how many devices you have sharing ONE IDE ribbon cable. If you have NO IDE devices now, then you need one data cable and you set the jumpers on the drive to be the Master. See the manual, page 10 (says 8 at the top). Plug the unit into the END connector on the ribbon cable. If you already have a Master device on your IDE cable, make sure its jumpers are set to Master and it is plugged into the END. (I don't recommend using the "CS" settings in this case - this old drive will not work that way.) Then set this old drive's jumpers to Slave and connect to the middle of the ribbon cable.

OK, with all this connected you can boot your machine and go directly into BIOS Setup. Go to the first screen where your IDE drives are described and configured. In the column for this drive where you set the drive Type, do NOT leave it at the default "Auto Detect" setting. Change it to the last of the numbered Types (I think I remember 47) and it will let you enter manually the parameters above for CYL, HD and SECT. Leave any values for Landing Zone, etc. at zero. When you get the line of parameters filled in, the disk Size column will be filled in for you to show 127.94 MB. Now just make sure your Boot Priority Sequence set elsewhere in BIOS makes NO attempt to use this drive to boot from.

Save and Exit from here and let the machine boot normally. When it is running you should be able to see the drive in Windows Device Manager and in Disk Management's lower right pane, at least. If it's all good, you will actually see it in My Computer and be able to access its files. I recommend you do NOT try to write anything to it, just in case the new Windows you're using does the wrong thing with such an old HDD. Just copy everything you can off the old unit to another place.
April 12, 2010 3:33:55 AM

Paperdoc
Thank you for that information. I have ordered the adapter from NewEgg. Should get here in a couple days, since NewEgg is close to me.
Related resources
April 16, 2010 4:50:33 AM

Received the adapter from NewEgg today. I plugged it into the Hd along with the Molex connector, then plugged that into a ribbon and attached that to the computer (Vista). Rebooted my computer and saw the st9144a recognized on the first boot-up screen, along with all the other devices.
Went to the Bios setup and found the st9144 there. All the parameters were already showing and locked, e.g., 980 cyl, 15 heads, 17 sectors. Went to device manager and found the st9144a there with message that it was working correctly. However, the device doesn't show up when I go to My Computer. Used Belarc Advisor to get my computer profile and the st9144a was recognized on the list.
My BIOS is Pheonix v 6.0 11/28/2005. In the BIOS, there are only two parameters that I can access. One of them is "IDE secondary Master", which I can set to "manual" or "Auto Detect". The other is "Access Mode", which is "LBA", "Large", "Auto" and one other that escapes me. What's next?
April 16, 2010 5:50:52 AM

I booted my computer using Knoppix Linux and found the st9144a mounted and accessible. Now, how do I get Vista to recognize it?
a b G Storage
April 16, 2010 1:08:16 PM

If you go to disk management in Vista, does it show up there? Right click on my computer, manage, disk management (there may be a quicker way to get there in Vista)?
April 16, 2010 1:53:29 PM

That option is not available in Vista, however, the disk drive shows up on the first boot screen where all the devices get recognized. It also shows up when I go to Device Manager>Disk drives and it showed up when I used Belarc Advisor to get the profile of my computer. And it shows up in Knoppix Linux and I am able to access the drive there. I think there is a mount command or something that I might need to get Vista to recognize this device.
April 16, 2010 4:08:07 PM

When you're running Vista, have you gone to the control panel > administrative tools > computer management > disk management and seen the drive recognised there. If it is there, see if it has been assigned a drive letter by the OS. If not you can try to assign one but depending on how the drive was formatted it may not be properly recognised by Vista and it will ask do you want to format it. Seeing as you want the data make sure you DON'T format it!
There may be ways to get the drive recognised properly but I'm afraid I don't know them. Can you use an older machine (eg one running XP or even earlier OSs instead to check the drive?)

April 16, 2010 4:10:54 PM

Found the my computer>manage>storage>disk management option, so it is available in Vista. First, I looked at this disk, and it showed up as unallocated. There were two options: Convert to GPt or Convert to Dynamic Disk. I clicked ton the GPT option and the disk showed up as a 32 MB volume. I didn't like that, so backed out and rebooted, then went back to Disk Management and clicked on convert to dynamic disk. Methinks that may have been a mistake, because when I click on my computer>Manage>Storage>Disk Management I am now getting a message "connecting to virtual disk service in the bottom of the window and nothing else. The hourglass just shows up and doesn't go away.

There doesn't seem to be any simple way to assign a volume number to this device and get it recognized.
a b G Storage
April 16, 2010 5:58:31 PM

http://www.microsoft.com/whdc/device/storage/GPT-on-x64...

"Creating GPT Drives

You can convert only empty, unpartitioned disks (raw drives or empty MBR drives) to the GPT format. To convert a volume that contains data, you must first manually delete the partition."

So the unused space, maybe the 32 MB, was converted to GPT. Can you see any other paritions on that drive? Each row under disk management should be 1 physical drive (I'm on XP here so I can't see for certain).
a c 342 G Storage
April 16, 2010 8:40:54 PM

First, in the BIOS screen the Access Mode probably should be set to "Auto" since it seems to have detected its parameters automatically. If that does not seem to work, try the LBA setting, which is really how we have been using HDD's for a while now.

In Disk Management you must concentrate on the LOWER RIGHT pane which scrolls to show you all the hardware devices present. Each physical device is represented by one horizontal block containing sub-blocks. The leftmost sub-block will be a small label with a ID like "Disk_3", a size, and a couple other items. To its right are one or more sub-blocks reach representing some of the space on the device. There may be one or more blocks that represent Partitions; each Partition will be treated as one separate logical disk. There may be one sub-block identified as "Unallocated Space". This latter is all the real physical space that has not yet been assigned to a Partition, so it can be used to Create a new Partition (or more than one).

For a Partition already created, the sub-block normally will show a disk letter name like D: , a File System like FAT32 or NTFS, a disk size, and a disk status. If it has no letter name assigned, you can RIGHT-click on the Partition and Change its name (or give it one) to anything not already used. If you do that, you must exit out of Disk Management and reboot your machine for Windows to update its Registry with the new info and start to use the disk.

If the Partition has a letter name but its File System is shown as RAW, there is a problem with the data in the Partition Table or in the Partition's own initial data structures so that Windows cannot understand it. In this case, you should search around here and the web for information on how to recover the data and restore a disk with a RAW Format. That is, IF there is data on it you want to retrieve.

Now in your case you seem to indicate that the disk may NOT contain anything useful. In that case I suggest you get rid of any trace of Partitions on it so the unit is like a new empty HDD, then proceed. Steps:

In Disk Management, RIGHT-click on any sub-block that looks like it is a Partition and choose to Delete this Partition. Do this to all blocks you see until there is only the little label block at the left and one block of Unallocated Space. Now, RIGHT_click on the Unallocated Space (your description above suggest you did a LEFT-click by mistake) and choose to Create a Primary Partition. In the ensuing dialogs make it the size you want (probably the whole disk) and you do NOT need it to be bootable if you're using it for data only. If you happen to be inside a helpful Wizard at this point it may also ask for Format specifications. If so, I suggest you choose the NTFS File System and a Full Format. The latter choice means it will do your basic Quick Format and then take an hour or two to exhaustively test the entire disk surface, marking off any weak sectors so Windows will never try to use them later. This is a good precaution when re-using a used older HDD unit. IF you were not being helped by a Wizard, you will have to run the Partition operation itself as one step, then RIGHT-click again on this new Partition to Format it. That's where you set the Format specs if this is a separate second step.

When all that is done, exit out of Disk Management and reboot for the Registry to catch up, and the disk should show up as usable in My Computer.
April 16, 2010 11:31:31 PM

Yesterday, using Linux, I was able to see the files that are on this HD. I think I did something wrong later in Windows when I clicked on "convert to GPT disk". Later, I clicked on "convert to dynamic disk". I don't know which of these actions fouled things up, or if it did. Now, I can't see the files in Linux and in "disk management" this volume is identified as 122 mb unallocated and there is no drive letter assigned. Right clicking anywhere on the volume does nothing to give me a way to assign a drive letter.

Is there a way to reverse the conversion that I did? I think it fouled up the partition table or something.
April 19, 2010 1:58:02 PM

No answers here for several days. Please, someone, help me out.
!