Sign in with
Sign up | Sign in
Your question

Crossfire enabled results in choppy crysis gameplay

Tags:
  • Graphics Cards
  • Games
  • Crysis
  • Crossfire
  • Graphics
Last response: in Graphics & Displays
Share
December 3, 2008 2:28:36 AM

Hi Guys,

I upgraded my rig today (yay!) although when i loaded up crysis to see what it could do i ran into an issue.

While playing crysis there is a problem with the framerate. The game is essentially unplayable with the issue i am having. During the game "hiccups" occur for every second or two of time that passes. between the hiccups the game will run normally. It is hard to describe, but the issue is not with the game constantly running at a low framerate.

My current system specs are this:

Vista 64
2 ati 4850's in crossfire mode
AMD phenom 9950
500 gig hdd
520W power
4gb of ram

onboard audio


Adjusting the resolution aswell as the graphics detailing do not help the issue at all unfortunately.

The way i play crysis is by dissabling crossfire and utilizing only 1 4850 card. With this setting i hover around 25fps at very high settings on 1920x1200 and there is no hiccup.

My system has not been overclocked, aswell i have uninstalled and reinstalled drivers. after uninstalling i ran windows install cleanup to ensure no ati driver files remained and rebooted the system between each uninstall/install process. I have also removed ram and swapped them around but came across no resolution.

From what i have tested i believe the problem to be with crossfire (as dissabling it resolves the issue hehe) but i am posting here in hope that you might have a suggestion or a fix.

Scouring google aswell as these forums i could not find anything relating specifically to my issue which included a resolution so as to be able to use my crossfire in crysis.

Looking for help,

a modest gamer...

*edit, Forgot to add that i have tested other games such as fallout 3 and they ran great with crossfire enabled so it seems to be just related to crysis. :S

More about : crossfire enabled results choppy crysis gameplay

a c 107 U Graphics card
December 3, 2008 3:01:03 AM

Yeah, crossfire doesn't like crysis. Seems like a case of micro stutter. having a faster CPU could aid the situation so you may as well overclock your 9950 since that's what the unlocked multiplier is for. Currently, Radeon drivers are not optimized to take advantage of multiple threads, which is why two 4870X2s get their asses handed to them by triple SLI'd 280's on an i7. AMD is working on it though so hopefully there will be drivers soon that take advantage of your multiple cores and thus alleviate your little dilemma there.
December 3, 2008 3:04:28 AM

ahh ok, well i guess ill just have to wait it out then :)  thanks for the reply megaman.

I was able to overclock to 3.0ghz on the cpu but the issue persisted and i wasnt able to notice any change.

Oh well, crossfire works in the games i want to play at the moment so it wont bother me too much.

hehe was hoping to see crysis with AA on at 1920x1200 at very high on my own rig.

*sigh*
Related resources
Can't find your answer ? Ask !
December 3, 2008 3:13:19 PM

Crysis very high 25 average at 19×12 with one 4850
December 3, 2008 8:08:21 PM

cyber_jockey said:
Crysis very high 25 average at 19×12 with one 4850



Is that bad?
a b U Graphics card
December 4, 2008 12:08:28 AM

It actually surprises me that it is that high. I only get about 35fps on very high with my 4870x2 (also at 1920x1200).
!