Sign in with
Sign up | Sign in
Your question

SATA2 Seagate speed dropped to 4MB/s

Last response: in Storage
Share
April 12, 2010 4:56:08 PM

Something happened to my less than a year old HDD. It was running fine until now.

My other drives have speeds from 57 to 70 MB/s - benchmarking in HDTune. The slow drive really kills the loading times of various games (from a few seconds to a few minutes, and from a minute to about 5 minutes).

I tried rebooting, didn't help. I tried to shutdown PC, disconnect drives power and data cables, and plug them again in - still didn't work.

This happened to my PATA drive once - but it just switched to PIO mode, nothing serious. I know that this can't happen to SATA drive, but it might switched to SATA I, right? But still the speeds wouldn't be as low as they are.
a c 127 G Storage
April 12, 2010 6:35:21 PM

Next time please mention what operating system you are using.

This sounds like a PIO issue; please use HDTune to identify the PIO issue. Run the standard benchmark. If it shows a horizontal line of no more than 16.6MB/s and has very high CPU utilization, then you are likely running in PIO mode.

Usually, this is remedied by going to the device manager and deleting/uninstalling the primary/secondary IDE controller. Or in your case the SATA controller.

Please note that this issue may be caused by cabling errors; if the above trick doesn't work post the drive's SMART info here. If the number of "UDMA error count" is higher than zero, you have cabling issues.
April 12, 2010 6:35:48 PM

Since I cannot edit my message, I have to bump this:

The problem was actually in IDE controller set to PIO mode :)  Reinstalled it and the speeds jumped to 70-80 MB/s ;) 
Related resources
!