Sign in with
Sign up | Sign in
Your question

Static IP default gateway issue under vista x64

Last response: in Networking
Share
April 23, 2009 3:56:49 PM

Hi there,

I have been running a vista x64 box with an ASUS wifi motherboard through a belkin G, wireless router. Although the other machines in my house use DHCP (setup as IP ranges 192.168.2.2-192.168.2.100 on the router) I would like to use a static IP on my gaming rig for better gaming.

I attempted to, taking note of my router's IP, subnet mask and default gateways but I have encountered an issue.

Having disconnected from the router, I proceeded to edit my network connections (for the wireless adapter) with:

IP 192.168.10.10
subnet 255.255.255.0
Default gateway 192.168.2.1
DNS 192.168.2.1

These were taken from running ipconfig /all and using them to set up my static settings.

Having pressed ok and then close in teh relevant dialogue boxes, I BSODed and was forced to restart. This happened several times. Eventually (and I do not know how) I was able to exit without crash. However, I was told that my default gateway was not on the same subnet as my router IP, despite the fact that I had kept both the same from the previous DHCP setup.

I was then able to connect to the router, but was not able to access the internet. I checked ipconfig and the subnet mask field was blank but all the other fields were correct. Going back to the network settings, my IP address, subnet and Default gateway settings had all been erased and replaced with 0s. On correcting this and exiting, I BSODed again.

Any ideas would be very helpful and my drivers are all up to date :) 

Thanks very much
Anonymous
April 23, 2009 11:48:27 PM

Where did you get the idea that a static IP is better for gaming?

Grumpy
April 24, 2009 9:54:33 PM

Well, for port forwarding, a static IP is required. Several games, plus other apps need it for proper performance.

Thanks for the reply, although I have managed to resolve the issue.

To anyone who is experienceing this issue, I believe it is caused by the router assigning you a preferred IP, whilst having a different static IP set up. Try turning off the preferred IP options under DHCP.
Related resources
Can't find your answer ? Ask !
May 19, 2009 4:17:43 AM

I didn't read what you wrote, but essentially give your host a static IP. Then set your router to forward ports to your host.

There is nothing more to it, its really as simple as that.

-Eric
May 19, 2009 7:43:51 AM

Thanks everyone, problem solved.
!