QX9770 and Gigabyte EP45-UD3R

Hi everyone! So i have a QX9770 that I was trying to install on a Gigabyte EP45-UD3R but it won't boot up or even go into my BIOS. It just turns on and off. I plugged in a my QX9650 and works fine. The board is suppose to support the QX9770. Any suggestions?
11 answers Last reply
More about qx9770 gigabyte ep45 ud3r
  1. ur rich very rich
  2. newer BIOS?
  3. Just updated to F6, using my QX9650. Tried the QX9770 again and nothing.
  4. tleonx said:
    Any suggestions?


    Ahhhh share the wealth!? Seriously sounds like the cpu could be dead. Do you know that it worked before you received it? I had a dead chip in the past that did the same thing.
  5. Well I did think about that. A coworker just got the same CPU and let me test it. Chances of two the CPUs being dead are pretty slim, i think. The only problem is his CPU hasn't been in system before either. He's in the process getting the rest of his build...
  6. I'd agree that the chances are quite low. The guru's here would probably know more but from the sounds of it, it could be the board or bios issue, if it works on your friends board well that would be the problem. Just curious, it might sound dumb but does the mobo support 1600Mhz FSB? Could be something easily overlooked, though I doubt it. Good luck.
  7. Yeah the Mobo does support 1600Mhz, I was hoping someone had the same CPU/mobo combo and maybe they either had the same issue or maybe got it to work somehow. You may be right though, perhaps the mobo they sent me may be defective. Thanks for the responses so far.....
  8. Part of the problem is that almost nobody has a QX9770 due to cost, so there aren't likely to be any others with a comparable experience.
  9. The mobo isn't defective if it runs the QX9650 just fine. Try putting that QX9770 into some friend's X48 based board and see what happens. Also, you might try to manually set the FSB to 333 before booting.

    Perhaps the board requires some extra volts on the NB in order to run at the QX9770's default of 400, so that it can't pass POST due to some poor regulation of the "AUTO" setting.

    You could simply take that CPU to any decent hardware store and ask for some help, stating that if some X48 board runs it in front of your eyes, you might buy it.
  10. Hopefully my co-worker ends up getting an X48 motherboard. Meanwhile I'll try the manual settings as you suggested
  11. Well guys turned out to be my memory. Guess the memory I was using was not fast enough (667mhz). I had some 1333 mhz on order anyways so not a big deal. Just thought that was weird that my QX9650 worked fine with the old memory., but not my 9770. Thank you all that replied.....
Ask a new question

Read More

CPUs Boot Gigabyte