Sign in with
Sign up | Sign in
Your question

Sony Vaio VGN-SR21M CPU cooling fan always on

Last response: in Components
Share
February 3, 2009 12:44:11 PM

Dear all,

one month ago I bought the laptop Sony Vaio VGN-SR21M, with Windows VISTA Home Business pre-installed.
During the first 15 day, the CPU cooling fan was adjusting its speed according to the workload and actual temperature.
Now it always works at its full speed, with a maddening background noise, that is unnecessary too.
Hardware monitors give me low temperatures for all pc components (25-30 degrees centigrades), and the outcoming air flow is cool indeed.
No patches or updates are available on Sony support sites.
I searched for related settings within the BIOS too, but I did not find anything useful (well, there isn't anything useful at all).

Someone already had the same problem?

Thank you in advance, and sorry for may bad english.
February 3, 2009 2:02:56 PM

See if you can override it with Speedfan
February 3, 2009 3:15:42 PM

pr2thej,

thank you for your suggestion.
I just tried, Speedfan doesn't read the fan speed. It reads temperatures only (that are 30 and 34 degrees centigrades for the two cores).
Related resources
February 11, 2009 8:57:47 AM

Dear all,

at last I did it.
I removed the battery for 30 minutes, then I reconnected it, and that's all. Now the fan is working right, adjusting its speed according to the workload (that is always low :-) ).

Maybe someone might want to know how did I find this solution.
I called the Sony call center, they told me that this was the first case (actually, there are a lot of threads in a lot of forums on this topic), and they instructed me to send them the laptop for assistance *without* the battery and any other accessory. I prepared the laptop as they said, but 30 minutes later or so, I wanted to check whether I removed all personal data from it. What happened next it's easy to be guessed.
To complete the report, I called back the Sony call center in order to give them a feedback on the problem, but the answer was that they are not interested in the solution. They only thanked me for avoiding their intervention.

Again, thank you all for your interest, and sorry for my bad English.
Anonymous
October 23, 2009 6:44:57 PM

Hi Estiqaatsi,

I had exactly the same problem (Vaio SR21M, air ventilation/fan always on). I took the battery out overnight and this morning it was fixed !

THANKS FOR YOUR STORY !!!!

Stan

estiqaatsi said:
Dear all,

at last I did it.
I removed the battery for 30 minutes, then I reconnected it, and that's all. Now the fan is working right, adjusting its speed according to the workload (that is always low :-) ).

Maybe someone might want to know how did I find this solution.
I called the Sony call center, they told me that this was the first case (actually, there are a lot of threads in a lot of forums on this topic), and they instructed me to send them the laptop for assistance *without* the battery and any other accessory. I prepared the laptop as they said, but 30 minutes later or so, I wanted to check whether I removed all personal data from it. What happened next it's easy to be guessed.
To complete the report, I called back the Sony call center in order to give them a feedback on the problem, but the answer was that they are not interested in the solution. They only thanked me for avoiding their intervention.

Again, thank you all for your interest, and sorry for my bad English.

Anonymous
March 10, 2011 2:56:10 PM

hey i have the same problem.....i read ur replies it does make sense but i am only ci=onfused about 1 thing that do you just leave the battery out and then leave your laptop at charging or do you just take the battery out and then leave it aside and the laptop shut down all night or for some time???
thankyou for ur support....
!