RAM incompatible with new board?

Hi all,

I continue my saga here on Tom's Hardware regarding my infuriating system. I apologize for this being a bit long, but there's a lot to explain. Here's the situation...

My computer would not turn on, and I discovered it was that the CPU had burnt the motherboard socket, rendering both useless. This was after I had bought a new PSU because initially I thought that might be it. I replaced them with the following:

ASUS M3A78-EM board
AMD Athlon 64 X2 7750 Kuma 2.7GHz processor

I also bought an identical stick of 2GB G.Skill DDR2-800 memory to accompany the one I already had. After installing all the new toys, I tried powering on the system and bingo! everything turned on. So I hooked up the rest of the stuff, including the monitor, and sat down to use my newly fixed computer, only now I got no display.

I scoured forums and did every test imaginable, and came to one conclusion: the RAM. It was not the video card first of all (obvious thought), because the on-board VGA input didn't work either. It's not the monitor. It was not the PSU because it's new. The new CPU and motherboard were both fine, because I could feel the CPU heat up with the heatsink removed, and the motherboard beeped without RAM in it. And I also removed the old 2GB stick and left only the brand new one in, and again, no dice. I used an eraser on the pins to remove static, and I also made sure it was well and truly seated.

With everything else removed, leaving only the mobo, CPU, and RAM, it had to be the RAM. Now here's two things that concern me:

First, the board that went bad was also an AMD board and my RAM worked fine in that, despite the G.Skill website saying it was Intel RAM (I had no idea it made a difference, but it still worked so what the heck). My new board only specifies one type of "compatible" G.Skill RAM, which I find odd, especially because it's also 2GB DDR2-800.

Second, after removing the heatsink to check that the CPU was operational (and determining that it was), I replaced it and powered on the system again with the memory removed. This time, I smelt something a little funny and immediately shut down the computer. I took a sniff (as you do), and could smell it coming from the GPU, which is admittedly very dusty and it smelt like burnt dust, but it worried me. When I removed the GPU and powered on the system again without the RAM, I got no beeps anymore, and haven't since. The board still has a power light, and the CPU still gets warm, but now I'm worried I might have done something to the mobo.

I have ordered new G.Skill RAM that is quoted in the ASUS manual as compatible, but what does it sound like the problem could be? I'm so tired of replacing parts and not knowing what the problem is that I'm almost ready to throw the whole thing out and start over.

Thanks also if you got to the end of the post. I appreciate it. :D
1 answer Last reply
More about incompatible board
  1. rma it and get an intel instead.

    i dont like the idea of running the cpu wthout its heatsink, and its usually worth the effort cleaning off the dust every now and then.

    im half inclined to think it might actually be your new psu as that was the thing that you changed prior to the first death, it might be new but its killing components, send it back if you can, get a decent brand one to replace it - corsair/coolermaster

    test the ram / video card in another machine to make sure they do work, burning smells in general arent healthy.

    im hoping the psu hasnt fried the new mobo/cpu/gpu.

    so, rma psu, mobo, cpu, ram, hmmm anything else you can send back?

    start afresh with a c2d or something nice...
Ask a new question

Read More

Memory RAM