Sign in with
Sign up | Sign in
Your question

Why Vista won't boot if I pick AHCI for SATA Mode

Last response: in Motherboards
Share
March 14, 2009 5:52:55 AM

In "BIOS - Integrated Peripherals - OnChip SATA" My Windows Vista will only boot if I choose "IDE" for the SATA Mode. Why doesn't Vista boot if I choose AHCI mode?

Thanks for help.

System:
Mobo: Abit IP35-Pro
RAM: 4x1GB Crucial Ballistix
HDD: Maxtor 320GB SATA - plugged into internal SATA port on mother board
GFX: nVidia GeForce 8800GTS
March 14, 2009 6:21:22 AM

AHCI needs different drivers to run the HDD's there are like hotfixes i beileve but normally your suppose to install the drivers and set the bios for ACHI mode for sata HDD's when you install your OS.
March 14, 2009 6:51:05 AM

martian1024 said:
In "BIOS - Integrated Peripherals - OnChip SATA" My Windows Vista will only boot if I choose "IDE" for the SATA Mode. Why doesn't Vista boot if I choose AHCI mode?

Thanks for help.

System:
Mobo: Abit IP35-Pro
RAM: 4x1GB Crucial Ballistix
HDD: Maxtor 320GB SATA - plugged into internal SATA port on mother board
GFX: nVidia GeForce 8800GTS


Izzycraft is correct. One should install the AHCI drivers during install. Here's a post for a possible work-around:

http://forums.pcper.com/showthread.php?t=444831

"Read carefully and decide if non-professional advice is right for you."

Why do you want AHCI mode, anyway? Most comon uses are for hot-swapping a drive. But your primary boot drive? Software caching? Why?

Unless you are building a raid 5 array or some such that needs to have hot-swapping capabilities, it is pretty much a waste.
Related resources
a b V Motherboard
March 14, 2009 7:36:02 AM

You actually don't need to install AHCI drivers for Vista. It can autodetect AHCI and RAID volumes just fine with no additional drivers needed. You do need to have it set in AHCI mode when you install Vista though - you can't install it in IDE mode, then switch it over later.
a b V Motherboard
March 14, 2009 7:47:15 AM

cgl has it. Vista doesn't need AHCI drivers at install, it has them already, but AHCI must be enabled when Vista is installed, so that Vista is aware that AHCI is enabled.
March 14, 2009 10:38:08 AM

If he didn't have ahci initiated in the bios when he installed the os, then the os didn't install the drivers. If he then went into the bios and initiated ahci after he installed vista, then guess what? BSOD. Croc and IzzyCraft are right. The only way to fix it is to reinstall the os with ahci initiated in the bios, because if you try to do a repair and have ahci enabled after you did the install in IDE mode it will wipe out the harddrive and you would have to reinstall the os anyway. Its the same way with RAID drivers when you want your Raid disk bootable.
March 14, 2009 1:45:37 PM

You do not have to reinstall VISTA to enable AHCI.


http://support.microsoft.com/kb/922976

1. Exit all Windows-based programs.

2. Click Start, type regedit in the Start Search box, and then press ENTER.

3. If you receive the User Account Control dialog box, click Continue.

4. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

5. In the right pane, right-click Start in the Name column, and then click Modify.

6. In the Value data box, type 0, and then click OK.

7. On the File menu, click Exit to close Registry Editor.
March 14, 2009 7:56:52 PM

spinetap,
You're Best Answer, worked for me :)  Thanks a lot for the link to ms support (they also showed me how to back up registry in case of problems) but went off without a hitch.

In answer to others who asked "Why would I want to change to AHCI?" You guys are probably correct in that there is no real noticeable difference in performance. But I have the ICH9 board so why not? If for no other reason, it's nice to know why something doesn't work the way I thought it should.

Thanks to all for "quicker than expected" replies - this forum ROCKS :) 
February 20, 2010 2:18:41 PM

This worked beautifully, thanks spinetap! Now I can plug in my external eSATA 2.5" drive withuot rebooting and my transfer rate has increased from 27mb/sec to 58mb/sec. Very much appreciated.
Cheers



spinetap said:
You do not have to reinstall VISTA to enable AHCI.


http://support.microsoft.com/kb/922976

1. Exit all Windows-based programs.

2. Click Start, type regedit in the Start Search box, and then press ENTER.

3. If you receive the User Account Control dialog box, click Continue.

4. Locate and then click the following registry subkey:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci

5. In the right pane, right-click Start in the Name column, and then click Modify.

6. In the Value data box, type 0, and then click OK.

7. On the File menu, click Exit to close Registry Editor.

March 3, 2010 3:08:22 AM

bashpheme said:
This worked beautifully, thanks spinetap! Now I can plug in my external eSATA 2.5" drive withuot rebooting and my transfer rate has increased from 27mb/sec to 58mb/sec. Very much appreciated.
Cheers


sounds like a good reason to go up to ahci to me thanks, ima try this on my new ssd
Anonymous
a b V Motherboard
April 5, 2011 3:31:09 PM

+1 to this

Also If you are running a newer motherboard you may find that the AHCI can be turned on or off on the ESATA ports seperately to the internal Sata Ports.

Certainly thats the case with my Gigabyte p67a-ud4-b3.

This just saves you the hassle of worrying about reg keys etc. as you aren't worrying about the boot OS HDD. I just had to ensure the AHCI drivers were installed and enabled it for ESATA.

Worked wonders for my External ICY Dock :-)
April 24, 2011 1:54:05 PM

cjl said:
You actually don't need to install AHCI drivers for Vista. It can autodetect AHCI and RAID volumes just fine with no additional drivers needed. You do need to have it set in AHCI mode when you install Vista though - you can't install it in IDE mode, then switch it over later.



Wrong.


Windows 'installs' SATA boot drivers and picks one at initial installation:

pciide.sys for IDE
msahci.sys for AHCI
IastorV.sys for RAID

It will only enable one by default, and refrain from loading the other 2.
This causes your windows to fail booting after you change your SATA controller setup in bios to another value.

In order to fix this non-booting issue, revert back to original configuration (so windows can boot) and:


1 open regedit
2 go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\
3 alter the regkey for 'start' from 3 (don't load) to 0 (do load) for the 'other' 2 boot drivers (see list above, they show up in Services by that name, 'start' is a key belonging to those .sys entries)

After having enabled the other 2, you can now freely alter your SATA configuration into whatever you like (IDE/RAID/AHCI) and windows will boot up properly every time.


Disclaimers:

- Tested and confirmed for windows vista, windows 7 by me.
- Windows only disables these 'unnecessary' drivers to enhance windows boot startup time, there is no driver conflict possible.. just an added 0.1 second wait while windows loads (if it is even that much, I don't notice a difference with 1 or all 3 drivers loading)


Original source by Microsoft:
http://support.microsoft.com/kb/922976

I hope this helps!
!