Safely remove hardware dialogue box empty

Hello,
No devices appear in "Safely Remove Hardware" dialogue box. I see USB, external HD in My Computer. THis started after I downloaded Blackberry Manager software and I cannot remove or repair it (Error 1706). Why doesn't Safely Remove recognize my USB's and external?
9 answers Last reply
More about safely remove hardware dialogue empty
  1. Can you right click on them in My Computer and safely remove them?
  2. Hi kilo-17,
    If I right click on PNY USB2.0 (G:)in My Computer and select "eject", the flash drive icon does NOT dissapear, but changes name to Removable Disk (G:). If I then right click on the icon as Removable Disk (G:) in My Computer and select Properties>AutoPlay>Actions> Open Folder to View in Windows Explorer, the folder does NOT open. (Good, right?) I have tried Error Checking, and System Restore. I also checked policies in Properties for Removable Disk (G:) and found Policies set to Optimize. I did not change these properties. If I double click on Removable Disk (G:), it does not open but "insert a disk into drive (G:)" appears so I assume it is safe to remove.

    I haven't tried this with my much more expensive Seagate Go Flex for fear of damaging it because the the light does not go out and I can feel the drive spinning.

    Thanks for your quick response.
  3. So, you can't actually browse the contents of disk G, it says to insert one?
  4. kilo_17 said:
    So, you can't actually browse the contents of disk G, it says to insert one?


    You are correct. I cannot browse or explore the "Removable Disk G. It says insert disk. I could browse or explore the disk before I selected eject and the name of the disk was changed from PNY USB 2.0 (G:) so I know the disk is operable and data is accessible.
  5. Then I would try removing the flash drive, sounds like the OS has ejected it. Then you can try putting it back in and see if all is well.
  6. When I open the Device Manager and select View Resources by Type, I get the following message: MMC has detected an error in a snap in. It is recommended that you shut down and restart MMC. I reported the error to Microsoft but do not know how to shut down MMC. I thought it might be a service but it is not listed separately in Services. So I stopped and restarted McciCMService and Windows Management Instrumentation Driver Extensions and WMI Performance Adapter (set on manual but I changed to automatic. Just took a shot. Safely Remove Hardware dialogue box is still empty although PNY USB 2.0 is seen in My Computer and in USB Mass Storage in Device Manager. Don't know if this is helpful or not.
  7. Try shutting your comp down and restarting it.
  8. I have restarted many times. My real concern is that my Seagate Go Flex is not offered the option to eject in My Computer. The drive continues to spin and the light remains on. I am forced to shut down computer and then disconnect Go Flex. I was hoping to restore the Safely Remove Hardware option. Microsoft is no help....no surprise.
  9. Might be worth a shot calling Seagate to see if they can help you.
Ask a new question

Read More

Drivers Hardware USB Windows XP