Sign in with
Sign up | Sign in
Your question

Intel Raid 5 not Recognized by Server 2003 after expansion

Last response: in Storage
Share
April 18, 2010 11:24:00 PM

This is really freaking me out. I have P55 motherboard with the PCH chipset. The reason I purchased this board is because I saw that the Intel chips could finally support expansion. I had 3 2tb drives, which were working fine(except for the random drive error from matrix 8.8). I am now using Rapid Storage 9.6. I followed the instructions to the t. I plugged in the new hard drive, and selected add to array. I then rebooted the machine and of it ran. It took 3 weeks to complete!

I am now left with an array that is not recognized by windows. It just says the drive is not formatted. It was still in the GPT format that I left it in, but somehow the drive was basic not dynamic anymore. So I converted it back to dynamic. Nothing. I have tried the repair option 4 times(desperate). Unplugged the added drive and removed it from the array, then rebuilt. Nothing. The Rapid Storage manager says the array is fine and working but windows does not recognize it correctly. It is still mounted as the same drive but something got corrupted. I was hoping someone could help with this. There is 4tb of data at stake here. Thanks in advance.
a c 126 G Storage
April 19, 2010 1:45:57 AM

Have you tried recovery programs? Apparently something went wrong during the expansion. This can happen; it is a dangerous procedure. You should not do this without backup.

Also, please remember RAID cannot substitute a backup - you're relying solely on the protection that RAID5 gives you, and that protection is degraded to RAID0 during the expansion process. Something to think about. :) 
April 19, 2010 4:45:52 PM

I figured as much. I know the repercussions of my actions. I appreciate your response but if I wanted a lecture I would go to my old lady. If anyone has something of substance to add, like a possible fix, I would appreciate it. Windows just does not read the array correctly(that is the fix I am looking for) I have run recovery programs on it to see if the data is still there and it is. I am currently running R-Studion on it now, but its 5.5 tb so I thought I'd ask the question in the wait time.
Related resources
a c 126 G Storage
April 19, 2010 6:00:32 PM

I can help you through recovery using Ubuntu Linux; with different RAID5 configurations. But that's a quite complicated route and would likely require you to open SSH access for me. It also wouldn't work if there is any damage on your filesystem; though it would be able to correctly access the virtual RAID-array as the problem might be RAID-layer related.

However, perhaps i'm not too optimistic about your recovery chances with this route. There are some recovery programs available on Windows that can both recover files from corrupted NTFS filesystem, as well as access the NTFS filesystem on a virtual RAID array; so the recovery program is accessing separate disks and creates a RAID array only for itself. This also requires you to use AHCI/IDE mode during the recovery. This may have a higher rate of success than the Linux/BSD recovery route. However, none of the good recovery apps that can do this are free, as far as i know.

Last thing i want to add, is that any action you perform right now may be destructive and may cause permanent corruption/inaccessibility. So if you're really sensitive about the contents, i wouldn't risk connecting them to windows ever again and go for 100% read-only recovery techniques.
April 21, 2010 1:38:19 AM

Thank you for your response mesa. I tried a little with ubuntu, but I did not want to unmount the raid drives from the intel controller yet. I am taking baby steps. I am running rstudio on the array now. I don't have to use its virtual array function since the array is recognized as a raid 5 array, but there is a lot of things like sector size and offsets I don't think it is reading correctly. We will see. This is my second scan the first one errored out at the end(after 2 days of scanning). So I am running another scan now with my fingers crossed.

I might take you up on your offer that is very generous of you. Thank you. I will post my results in detail if I do get this thing back. I "rented" a 4tb drive from fry's ready for data recovery.
June 28, 2011 12:59:08 PM

pjsallday - Any update here? were you successful in recovering the data?
a b G Storage
June 28, 2011 11:28:45 PM

When you expand a raid volume, after it's done you should have a RAW portion of a volume in Disk Management.

If you have a BRAND NEW VOLUME and Window want to initialized/format. That is a BAD sight! You may lost your data.

I would call Intel or MB manufacture and ask for help!
!