Sign in with
Sign up | Sign in
Your question

AHCI enabled still reading IDE

Last response: in Storage
Share
April 20, 2010 8:34:08 AM

I am confused now. I enabled AHCI and did a fresh format of my drives in windows 7 professional x64. The issue is that all my sata drives are still being read as IDE by the bios and by windows. Any help would be appreciated.

Forgot to mention its a CrossHair III mother Board. Enables AHCI BEFORE fresh 7 install, got it all installed and the bios says AHCI is enabled, yet next to each drive there is a IDE term next to them.
a c 127 G Storage
April 20, 2010 11:49:02 AM

How did you convince yourself the disks are running in IDE mode? You say you selected AHCI, but you seem to think it is still running in IDE; what makes you think about that?
m
0
l
April 20, 2010 4:49:49 PM

Sorry my iphone fails at typing. That would be very vital information sorry i forgot it. The devices are all have IDE next to them in the bios and device manager list them all as ATA devices rather then ahci or sata. That and there are no hot swap options
m
0
l
Related resources
a c 415 G Storage
April 20, 2010 11:02:25 PM

When you look in Device Manager under "Disk Drives", it's perfectly normal for the drives to be displayed as "ATA" even though the controller is operating in AHCI mode.

Similarly, you'll see all your SATA channels listed as "ATA Channel x" under "IDE ATA/ATAPI controllers". However at the end of the ATA channels you should see a device labeled "Standard AHCI 1.0 Serial ATA Controller"
m
0
l
April 20, 2010 11:55:19 PM

Is it normal to see them listed on bios with IDE next to them?
m
0
l
a c 415 G Storage
April 21, 2010 12:08:59 AM

Depends entirely on what BIOS you're using.
m
0
l
April 21, 2010 12:20:46 AM

How do I find out? If by chance you know. I hve a Asus crosshair iii
m
0
l
a c 415 G Storage
April 21, 2010 2:04:20 AM

Sorry, I don't have any experience with that MoBo so I can't really comment.
m
0
l
!