Sign in with
Sign up | Sign in
Your question
Solved

Problem with reading of cpu speed in cpu-z in windows 7

Last response: in Overclocking
Share
March 18, 2010 3:36:28 AM

Hi guys - D0NuT here,

I have recently installed windows 7 64bit OEM on my custom built pc. I recently had xp 32bit running just to check if the system worked. On the xp system i overclocked my i7 920 (stock cooling) to 3GHz (3.15 with turbo), i switched my blck to 150 and then left everything else on auto. I had ran prime 95 for 1 hr on xp and it was fine running at around 68-75 degrees on 100% loadout. I then installed windows 7, leaving the overclock the same (shouldnt make any difference). I installed cpu-z and restarted the pc. Once restarted i brought up cpu-z and then got a cpu speed reading of 3150 MHz (normal). I closed cpu-z and then reopened it later to find my cpu speed was recognized at 1800MHz!!!!!!!!!!!!!! This is really random because all settings are normal. Could anyone help? Is it the program?

My specs are:
i7920 (ocd to 3GHz)
gtx295
p6t motherboard
1.5TB HDD
Windows 7 pro 64bit
6GB of DDR3 Kingston Hyper x ram.

Please help.
Cheers
March 18, 2010 3:42:48 AM

oh btw i just put my cpu bclk back on auto again and works fine and correct amount showing up. any help with the cpu-z thing would be great thanks.
m
0
l
a b à CPUs
a b $ Windows 7
a b K Overclocking
March 18, 2010 4:32:46 AM

You do realize that speed step will adjust the speed of the CPU to whatever you are doing, if you are doing nothing, it will slow way down. It is a power saving feature in the BIOS. When you load up a game, or start any applications, it will speed up. If you want the CPU at full speed all the time, you have to turn that feature off in the BIOS. Let me know if that is what you need to know, or if it is something else.
m
0
l
Related resources
March 18, 2010 4:36:54 AM

REALLY! i had no idea about that! im pretty noob at this OC stuff. Man you are a hero. so I just turn speed step off and then should work fine?
m
0
l
a b à CPUs
a b K Overclocking
March 18, 2010 6:00:01 AM

In order to turn off speed step, you have to disable C1E, C3/C6/C7 and EIST in the BIOS.
m
0
l
March 18, 2010 6:59:07 AM

I am not to sure what is meant by c1e, c3c6c7?
m
0
l

Best solution

a b à CPUs
a b K Overclocking
March 18, 2010 7:13:47 AM

you don't need to disable speedstep. you are not losing performance, it simply downclocks to save energy.

leaving it enabled means less power and less heat, which in turn means a longer life for your processor. and you won;t gain any performance, except for perhaps the split second between when you load an app and speedstep kicks up the processor speed.
Share
March 25, 2010 10:51:07 AM

Best answer selected by d0nut.
m
0
l
!