Sign in with
Sign up | Sign in
Your question

Intel Matrix RAID 0,1 degraded, acting illogically

Tags:
  • Hard Drives
  • NAS / RAID
  • Matrix
  • Intel
  • Storage
Last response: in Storage
Share
April 22, 2010 1:31:18 PM

i have a little conundrum right now with my RAID array. it says a hard drive is broken, but its operating normally, as far as i can tell.

my info: intel quad-core with intel ICH10R Raid controller
gigabyte UD45-EP
dual 640 Western Digital Caviar Black HD
windows 7
all about 9 months old now

i run a RAID 0,1 array, using the intel matrix storage manager. i set up the array in the bios, but the manager itself runs through windows. i've got all my important info and my OS on the RAID 1 side (labelled "mirror"), and the programs on the RAID 0 side (labelled "stripe").

when i boot the computer, i am told:

one of my physical drives has an error "error occurred"
my RAID 0 partition is "normal"
my RAID 1 partition is "degraded"
in windows, a box says some data on the RAID 0 partition failed and i should back up.
(this info comes through the intel matrix storage manager when my computer is booting up)

it seems that there is a problem with one of my hard drives, and indeed its probably failed in some way. but everything is working fine. i ran diagnostics through windows 7 and they say my physical hard drives are okay, and i got the diagnostic from Western Digital but that thing was completely screwy - it gave me a cable error on both, which is clearly untrue, and thought my serial numbers were wingdings. the only thing that seems to think i have a problem is the Intel Matrix Storage Manager. plus - if a drive is busted, why isn't RAID 0 partition be degraded (or even failed) as well, instead of normal?

what should i do here? obviously i've backed up everything important, and i feel like i should RMA my hard drive. but it seems like such a pain in the butt (i'll have to reinstall all my programs onto the RAID 0), and right now i am skeptical about how much is really going wrong. i'm using the computer right now, 3d modelling like normal. is there another diagnostic program that is reliable, or a way to simply repair my hard drive?

thanks for your help.

matt

More about : intel matrix raid degraded acting illogically

a c 127 G Storage
April 22, 2010 1:37:15 PM

You run RAID, so you cannot access SMART info directly.

You would need to download, burn and boot Ubuntu, then install smartmontools in a terminal, then use that package to get the SMART data on your drives, to see if they have any pending sectors.

So:

1. download ubuntu from ubuntu.com
2. boot ubuntu
3. Applications->Accessories->Terminal
4. sudo apt-get install smartmontools
5. sudo smartctl -a /dev/sda

The last command should give you alot of data; check for two things:
- Current Pending Sector (unmapped bad sectors; should be ZERO)
- UDMA CRC error count (indicates cabling errors)

Check all your HDDs this way and post the SMART data here if possible. Check for the two mentioned properties and confirm they have a raw value of 0 (zero).
m
0
l
April 22, 2010 11:42:46 PM

okay.

i'll do this because if i have to, but there has to be something to access my SMART data thats not a new operating system, because i don't currently run ubuntu. if anyone knows of something, i would appreciate it.

matt
m
0
l
!