Sign in with
Sign up | Sign in
Your question

How to have external harddrive recognized

Last response: in Storage
Share
Anonymous
a b G Storage
April 22, 2010 9:52:47 PM

Hello,
I have an external hard drive: ICONBIT HD270HDMI and I was able to make it work the very first time. Now not only it is not recognized by my Windows7, MAC, XP sp2 & 3, Vista on multiples pcs, but the system cannot find it under my compter=>manage : it's not there.
I have downloaded the latest firmware (.119)and applied it thru my TV (this HD is also a multimedia player).
I can watch movies but I cannot make it recognized. It works from time to time on a couple of laptops (win7)
I have btw the latest updates on Windows.

If I plug the HD into a pc, we hear the sound but at the right hand side, it says "unknown device". I tried swapping usb cables.
Has anybody encoutered any situation like this ?
thank you so much in advance.
a b G Storage
April 23, 2010 12:57:49 PM

It could be dead - have you tried contacting the vendor for support or an exchange?

I tried googling the drive for more info, looks like it's Russian? What does the HDMI in the product name refer to - you mention a USB connection to the PC - is that correct?
m
0
l
May 8, 2011 5:19:43 AM

Hello,

I was given by a Russian acquaintance this media player in January 2010 and had encountered the exact same issue. I tried it once, it worked then never again.

I remembered trying all types of OS and even platforms, like Linux, MacIntosh without any success. I upgraded the same firmware as yours.

The only computer that recognized it all along was the ACER Gateway. I never had trouble with it.

I wrote to the Iconbit newsgroup. No success.

One day , without trying anymore, I was given a second hand desktop
Intel Pentium 4, 64 bit with Windows 7 Ultimate and it worked fine.

I think installing Windwos7' latest updates might have helps but more importantly, they were both, ACER Gateway and Intel Pentium 4
***64 bits***. SO maybe try with a 64 bits ?


Hope this helps.




Quote:
Hello,
I have an external hard drive: ICONBIT HD270HDMI and I was able to make it work the very first time. Now not only it is not recognized by my Windows7, MAC, XP sp2 & 3, Vista on multiples pcs, but the system cannot find it under my compter=>manage : it's not there.
I have downloaded the latest firmware (.119)and applied it thru my TV (this HD is also a multimedia player).
I can watch movies but I cannot make it recognized. It works from time to time on a couple of laptops (win7)
I have btw the latest updates on Windows.

If I plug the HD into a pc, we hear the sound but at the right hand side, it says "unknown device". I tried swapping usb cables.
Has anybody encoutered any situation like this ?
thank you so much in advance.

m
0
l
May 8, 2011 5:20:25 AM

Hello,

I was given by a Russian acquaintance this media player in January 2010 and had encountered the exact same issue. I tried it once, it worked then never again.

I remembered trying all types of OS and even platforms, like Linux, MacIntosh without any success. I upgraded the same firmware as yours.

The only computer that recognized it all along was the ACER Gateway. I never had trouble with it.

I wrote to the Iconbit newsgroup. No success.

One day , without trying anymore, I was given a second hand desktop
Intel Pentium 4, 64 bit with Windows 7 Ultimate and it worked fine.

I think installing Windwos7' latest updates might have helps but more importantly, they were both, ACER Gateway and Intel Pentium 4
***64 bits***. SO maybe try with a 64 bits ?


Hope this helps.




Quote:
Hello,
I have an external hard drive: ICONBIT HD270HDMI and I was able to make it work the very first time. Now not only it is not recognized by my Windows7, MAC, XP sp2 & 3, Vista on multiples pcs, but the system cannot find it under my compter=>manage : it's not there.
I have downloaded the latest firmware (.119)and applied it thru my TV (this HD is also a multimedia player).
I can watch movies but I cannot make it recognized. It works from time to time on a couple of laptops (win7)
I have btw the latest updates on Windows.

If I plug the HD into a pc, we hear the sound but at the right hand side, it says "unknown device". I tried swapping usb cables.
Has anybody encoutered any situation like this ?
thank you so much in advance.

m
0
l
Related resources
!