Sign in with
Sign up | Sign in
Your question
Solved

Installing an SATA dvd burner

Last response: in Storage
Share
April 24, 2010 5:10:55 PM

Hello,
I upgraded from an EIDE CD burner to an SATA DVD burner on a older build. Two cables and four screws later, and I'm ready to go, I thought. Ran through the setup BIOS. The floppy was there, (Yes, I know it's really old school, but it's the only floppy left in the 5 piece LAN at my house), the Seagate EIDE (backup/storage), and the WD 500 SATA primary were present and accounted for. The LG GH22NS50 was also there, like you would expect. I set the boot sequence to floppy, DVD, WD 500. Save and exit. Everything loaded normally, XP Pro sp3 found the LG drive, installed drivers and reported "Ready to use". The drive is visible in "My Computer". If you put a disk in the drive, you can see the directories on the disk, but if you try to read(open) a folder, you get a quick BSOD followed by an immediate reboot. I contacted the LG customer service and was advised, by a form letter, to re-install the driver and check with the sofeware supplier, as it can't be a drive problem.(It came bundled with Nero Essentials, which I had to load through a SONY USB drive.)

After 2 weeks of e-mails, they agreed to take a look at the drive. I sent it in, they checked it out, said it was fine and sent it back. In the interim, I tried the drive in two other computers with similar results. (an Asus K8V-MX/Athlon 64/Xp Pro sp3 and a Gigabyte GA-G41M-ES2L/Dual core Intel/ Xp Pro sp3)

Convinced that it must be the drive, I purchased an Asus DRW-24B1LT. Same problem. I suspect it has something to do with the configuration/ set up of the SATA controller, but there doesn’t seem to be a lot of knobs that you can turn. The easiest thing might be to just get an EIDE burner, but that really seems like going two steps backwards.

Anyone have a solution?

Best solution

April 24, 2010 5:21:19 PM

check Bios for SATA controller and make sure it is marked as IDE not PIOS, this will cause an issue with most older systems running WinXP. (apparently fixed with Windows Vista/7) This is to ensure your SATA connector is acting like an IDE (PATA) drive and should no longer give you issues. I to had same issue on older machine but as soon as it went in new machine running Win7 worked fine. Older PC had to change this manually but worked after.
Share
April 25, 2010 3:55:17 AM

Rattman 169,

Thanks for the reply.

The only BIOS choice I have for the SATA controller is enable/disable. I have an older 80 gig WD ide as a primary ide, a 500 gig WD SATA as the primary SATA. When I plug in the burner, it is the secondary SATA. Oddly enough, I get a "disconnected Z drive" notice in "my computer."

I'll try the drive in the Gigabyte build tomorrow. I see what that bios has for choices. That is a fairly new build (6 months ago) I did to hook up to the 46" Visio in the living room.

Miketr007

m
0
l
Related resources
April 25, 2010 7:08:57 PM

Update-

I put the NG drive in the Foxconn A79A-S build - the only other computer that I didn't try- and without doing anything special, the drive worked as expected. No stuttering, BSODs, hard lock-ups. I'll try the Asus next, to make sure it is functional, then see how it works in the Gigabyte unit.

A BIOS update to the MSI may be in order.

miketr007
m
0
l
May 5, 2010 1:05:03 AM

Best answer selected by miketr007.
m
0
l
May 10, 2010 2:11:13 PM

see, they never tell you things like that, I had to read my Motherboard manual and it told me to change this setting, I was like you are kidding me, that's the problem and sure enough it solved my issue. Boy was I not happy, as a network admin and A+ Certified Tech it was a little bit annoying to have to change little things that should be set this way from the beginning.
m
0
l
!