Sign in with
Sign up | Sign in
Your question

Complex/Annoying hard drive issue, need help

Last response: in Storage
Share
April 26, 2010 8:15:41 PM

Hello,

I'll try to lay this out simple, as I tend to get carried away in forum posts...

Goal: Moving two WD raid0 hard drives from an old PC into a newer PC. Just trying to get some files from them---i.e. I do not want to clear/format/use them, just pull files from them.

Issues:
1. Raid is not set up on newer PC
2. BIOS freezes after about 3 seconds.
3. Main hard drive on the newer PC(not the ones im transferring) will not boot---that is, I AM UNABLE TO USE WINDOWS, and am doing everything via Ubuntu live.
4. Regarding the bios freeze, I have no PS2 keyboard to use if that is the issue (only usb wireless)
5. I cannot simply reconnect the HDDs to my old pc because its PSU is done.



Question: CAN IT BE DONE?



Appreciate any help, input. straight forward "No"s are welcome.


Background: My harddrive fails to boot windows, getting some 0x000000024 error, tried googling to fix it but no luck. Was going to build a new pc anyway so decided to just get my files from my hard drive using ubuntu (successful). I thought while i'm at it, why not connect the hard drives of my older PC (raid0 ones) to this one, use ubuntu and grab ALL my data together in one place. But didn't take into consideration setting up raid0...
April 26, 2010 8:20:05 PM

P.S. Setting up the raid without windows and limited bios use is the real issue---i can do the ubuntu stuff myself, for those that aren't familiar with it.

THanks again!
m
0
l
April 26, 2010 9:30:28 PM

HA! i got it!!!!!! all by myself!!!! yessssss!!

never have i ever done any hard drive setting up before.


i also read somewhere that setting up a new RAID on a different chipset you'll definitely lose all of your information that was on the drives previously, but mine is all here!!!!! :D 

thanks for the encouragement everyone........lol.

For those that searched:

I have an asus p5n32-e sli plus mobo.


First, I connected my two old drives.
Booted, noted which sata slots the drives used (3 and 4 in my case) on the POST screen---i think that's what its called.
Pressed DEL to enter bios -----repeated this step several times because of my freezing issue, eventually worked.
Need to go to the advanced tab, onboard device configuration, enable RAID
Reboot
you will get a new screen after POST that says press F10 for raid setup----do that.
set the first box from Mirror to stripe (for raid0), the next box i left at Optimal
then use the arrow keys to move the two drives listed from the left to the right
press F7, it asks if you want to clear data..in my case i pressed NO because that is the whole point of this operation.
verify the next screen lists the settings accordingly.

reboot from CD with ubuntu live

your drive should be listed and data accessible!
m
0
l
Related resources
a c 342 G Storage
April 27, 2010 5:37:25 AM

Hurray for you! You are very lucky that the RAID system built into the chipset of the new mobo is apparently almost identical to the system used to write the data to the two RAID0 drives. So the new system understands the old data layout.Sometimes this works out well, especially if the new mobo chipset is by the same manufacturer as the chipset on the old mobo.
m
0
l
April 27, 2010 7:33:08 PM

that's what I read as well and figured i'd have no luck.

actually, i read that after I had connected everything and booted----and it also said i'd probably lose all my data !!


but interestingly enough, old pc used an Abit AMD board and this one is an asus intel board.....


suppose i'm very lucky!
m
0
l
!