*Solved!* PC hangs at auto-detect AHCI Drive HELP!

Thanks in advance!

My machine is configured to use AHCI mode. I was reinstalling Windows 7 Ultimate (due to O/S corruption) and everything was going fine until it had to reboot for the first time during setup. Machine turns on, and it goes to auto-detect AHCI 1 in post, which is my primary HDD (two month old WD Caviar 1TB Black edition). It would just sit at auto detect for as long as I would let it. Once a half-hour went by, I figured it wasn't going to detect.

Here is what I've done: Swapped out Sata cables, still no go. Flashed Bios, still no go. Un-plugged all Sata devices except primary HDD, still no go. Tried different Sata channels on board, still no go.

What is strange is if I configure the bios to not use AHCI and use IDE mode (which is the default), Windows 7 installs without issue. I installed HDTune and all criteria under health reports ok. I ran a benchmark using HDTach and numbers were where they should be.

After the install, I tried rebooting and changing back to AHCI mode, however it still hangs at auto detecting the primary HDD. So I swapped the channel for my primary HDD to channel 3. I boot the PC and it auto-detects my other HDD and burner fine, however it hangs at auto detecting the new channel my primary HDD is on.

Again, everything works like a charm if I have drives configured as IDE. I have been running the PC in AHCI mode since Feb and have not had any issue at all.

I am at my whits end as to what may be wrong. How this happened makes no sense, nor how it functions fine in another mode. All hardware diags report the drive is fine. If the controller was shot, wouldn't it also fail to work in IDE mode as well? Any insight anyone could give would be deeply appreciated. = )

Again, thanks a ton, guys!

Asus Maximus Formula Intel X38 Chipset
BFGTech 550 Watt PSU Modular
Intel E8400 3GhzX2
4GB DDR-2 800MHZ
BFGTech GeForce 8800 GTS OC2
WD 1TB Caviar Black Edition Sata-2
WD 250GB Sata-2
Liteon Sata DVD/CD-Burner
Audigy 2 ZS
Windows 7 Ultimate X64
9 answers Last reply
More about solved hangs auto detect ahci drive help
  1. Solved!

    I did the following:
    Booting in IDE mode with Windows 7 DVD. Chose repair option. When options screen appeared, I chose command line.

    At the command line type: Diskpart
    This will begin Diskpart
    Type: LIS VOL
    This lists the volumes on the PC.
    Using this list, find the disc you wish to erase, fully. This process leaves the entire disc in an un-allocated state.
    Type: SEL VOL 2
    Again, choose the volume number relative to your PC needs.
    Type: CLEAN
    and hit enter.

    Exit out of repair and reboot. At bios screen, enter bios and change SATA drives from IDE mode to AHCI mode. Save and reboot.

    Now you have a fresh disc to install Windows 7 on without corruption or worries.

    Auto-detect problem fixed. ; )
  2. THANK YOU! been trying to fix this for SOOOOO long and stumbled on this. Thank you for taking the time to post your fix!
  3. Thanks!
  4. Thank you very much crimsonking.
  5. Thank you very much crimsonking, that really easy trick solved the auto-detect issue for me too!
  6. Thanks so much .... it worked for me on a Skt 775 system running an SSD with Win 10. Friggin awesome man .... :bounce:
  7. Thank you so much! Worked fine for me for WD320GB SATA HDD on ASUS P5B.
    You can use any tool to delete partitions from the drive that makes AHCI hang, such as Linux's 'fdisk' or 'parted' (I used Acronis, since I had that CD nearby - choose "Insall a New Hard Drive" under "Tools and Options" menu, this will delete all of your drive's partitions).
  8. Thank you!
  9. Thank You!
Ask a new question

Read More

Hard Drives Storage