Sign in with
Sign up | Sign in
Your question

4870x2 driver problems?

Last response: in Graphics & Displays
Share
December 17, 2008 5:17:25 AM

Ive decided to get an ATI Radeon Hd4870X2 and want to know if there r any problems with he ati drivers for vista.... im usin vista ultimate 32 bit....

ive also heard the HIS version has problems....

More about : 4870x2 driver problems

a b U Graphics card
December 17, 2008 5:18:13 AM

I'm running one, and I haven't had any trouble.
December 17, 2008 5:20:30 AM

@cj
do u use vista???
Related resources
December 17, 2008 5:24:09 AM

I also want to know from hd4870x2 owners if they experience ne real problems with overheating ...
a c 169 U Graphics card
December 17, 2008 5:26:28 AM

I dont have any problems too :D  i had XP 32 and now i have Vista 64,no probs at all :D 
a b U Graphics card
December 17, 2008 5:49:31 AM

Yep - Vista x64. Catalyst 8.12 does seem a bit flaky for me, but 8.11 is rock solid.
December 17, 2008 5:51:50 AM

k... i guess there arent tht many probs and it depends on ur luck .. if u get a defective card or not ... i want to know which brand i should go for when i get the card...
a b U Graphics card
December 17, 2008 5:59:43 AM

Mine is a Sapphire.
December 17, 2008 6:03:18 AM

ne probs with overheating???
a b U Graphics card
December 17, 2008 6:43:02 AM

Nope. At stock, it ran hot but within acceptable limits, and I used Rivatuner to bump the fan profile slightly. Now it idles at 60C and hits a max of 80C load (stock was 80C idle, 90C load).
December 17, 2008 6:48:06 AM

k... thnks cjl for all the input...
i think ill go for the 4870x2 probably saphire or palit
thx again
December 18, 2008 12:12:56 AM

Vista ultimate 64 bit
VisionTek 4870x2

no problems with anything using drivers 8.12

I bought the visiontek because it has a lifetime warranty
December 18, 2008 4:17:31 AM

lifetime warranty sounds gr8 .. will check into it ...thx sciggy
December 26, 2008 8:29:47 PM

Vista x64 - CCC8.12 - Flaky is an understatement!

I even reset my raid, reinstalled vista ult. 64, and first thing I did was install 8.12 - bang - next reboot crash after entering password before aero is fully up.

I can restart - hit F8 and boot into low resolution mode (640x480), then adjust my display to 1280x1024 but no higher or it will lock up instantly!

So now my 2 20" 1600x1200 displays are reduced to 1 at 1280x1024.. not really an acceptable solution at this point, but it is allowing me to write this post and search for other fixes...

BTW: I am running a stock Diamond 4870x2 with overdrive enabled ONLY to fix the fan at 31% or 50% depending on tasks... temps are 45 to 60degC always.

System:
Mobo: Asus P5E3 Deluxe (x38)
CPU: Intel Core2 Extreme Quad QX9650 3.0GHz
RAM: Corsair 2x2GB DDR3 (1033,9,9,9,24)
HDD0: Seagate 2x 200GB SATA-1 (Raid 0 usually but now Raid 1 until I get this driver issue worked out)
HDD1: Seagate 4x 500GB 7200.11 SATA-II (RAID 10)
PSU: Coolermaster 1kW
CASE: Coolermaster Cosmos - plenty of room and cooling - cpu temp is 32deg C right now...
VIDEO: Aforementioned Diamond/ATI 4870x2 2GB Reference spec
OS: MS Vista Ultimate x64


Was on XP x64 - had problems with ati 3870, hoped vista 64 would be better - isn't, hoped 4870x2 would be better isn't :( 


Has anyone had similar problems and been able to resolve them?? It seems like the drivers are TOTALLY hit and miss! My system so far is a MISS!

I have tried uninstalling 8.12 - driver cleaner in safe mode, re-install 8.12 sometimes works for a little while - less than 1 hour - then crash and back into the same cycle of failing just after login before aero is up.

running in low res mode system is stable as can be - but 1 display at 1280x1024 is NOT acceptable.

Sorry for my rant - I am incredibly frustrated at this point!!!!
!