Sign in with
Sign up | Sign in
Your question

Crossfire no POST display

Last response: in Graphics & Displays
Share
December 20, 2008 7:31:06 PM

Hi all

My system is getting on abit so decided to pickup a x1950xtx master card, to go with my slave so I could run it in crossfire.

I have an Asus P5W DH Deluxe motherboard with a connect3d master and saphire slave. For anyone that knows the P5W DH, the master is in the orange slot and the slave in the black. I can't see anything that needs changing in the bios (v2801) and it didnt say you had to change anything in the manual.

When connected in crossfire with the y dongle cable the system wont display a POST screen, the cable is plugged in to the master and the dvi slot on the slave immeditatly below, if you unplug the monitor then plug it back in you can see the Windows login sceen ok. Both cards appear in the device manager. I dont get a crossfire option in the CCC. Could this be an issue with the y dongle?


Thanks in advance

J

More about : crossfire post display

December 20, 2008 7:45:50 PM

So how did you go about installing the cards ? You didnt just swap the slave to the black slot and put the master in the orange slot, did you ? You should have a Crossfire option regardless i would have thought. If you uninstalled the original card and installed them in the correct order before reinstalling the drivers then im not sure what the problem could be.

mactronix
December 20, 2008 9:51:48 PM

I removed the drivers, shut the system down then removed the slave from the orange slot and fitted it to the black slot then fitted the master to the orange slot. Connected the dongle to each card and to the screen, but when it started it would't display the POST screen but I could hear the system had started. So unplugged the cable and refitted and the display came on at the login screen so reinstalled the drivers, then rebooted and again no POST screen. Ended up just plugging the DVI cable into one card so I could check they had it installed ect, both appear in the device manager.
Related resources
December 21, 2008 8:27:22 AM

Have you tried leaving it for a bit during post ? I had a niggle in the back of my mind about this so have done some searching and found what it was that was bothering me. If your monitor does not support the Extended Display Identification Data (EDID), or it has an incomplete EDID, it may result in the screen going blank during system post and boot up. This if it was teh case for you would mean that the screem would come up with a display after post.

Mactronix
December 21, 2008 8:31:43 AM

Also check the bios again as there usually is a setting for enabling crossfire.

Mactronix
December 21, 2008 9:13:17 AM

I've checked through the manual again and BIOS, can't see anything. I left the pc to boot and went to make a drink and it was still just showing a blank screen (Samsung 226BW) with the power button flashing. I think it must be the link cable because the card is seen in the device manager, but there is still no crossfire option in the CCC. I'm using 8.9 Catalyst Drivers again as they were working fine with the single card.
December 21, 2008 11:56:26 AM

Yes it would look like the cable is the next thing to look at.

Mactronix
December 21, 2008 12:10:06 PM

Im not sure but keep wondering if there is some sort of conflict with the Motherboard and the Master card. I mean from what i can remember the first crossfire cards with slave and master worked on the Y dongle then the interconnect was done on the motherboard and then the Pcie bridges. So what im thinking is your motherboard is trying to interconnect the two cards and your trying to use the dongle which could be causing a clash. Gotta admit im only guessing at this point but to be honest your issue has me intrigued. I will ask about on other forums to see what i can find. do let us know if you fix it in the mean time.

Mactronix
December 21, 2008 12:44:31 PM

The motherboard is 2 years old and was out the same time as the card was released, it has a whole section on crossfire in the manual and only mentions the dongle connection, so I think it pre dates the current generation ribbon-like connector. I'm going to try just the master on its own later, just to check I haven't bought a dead one, as I know my slave works fine.
December 21, 2008 2:13:41 PM

I've just removed my slave card and the creative xf-i, as i'd read there might irq issues with the two. So with just the master card in the orange slot, still nothing. No post display or anything once windows has started, looks like its a faulty card :( 

I've contacted the seller, so will await a responce.

Thanks for the help Mactronix
December 21, 2008 3:06:22 PM

No worries hope you get it sorted.

Mactronix
!