Sign in with
Sign up | Sign in
Your question

HD 4830 hanging when going fullscreen

Last response: in Graphics & Displays
Share
Anonymous
December 21, 2008 3:50:46 PM

Hi. I just got a Sapphire HD4830 card, and it seems to be giving me a couple issues.

1) Whenever I'm playing a game in fullscreen mode and alt tab, change resolution, or exit the game I freeze for 10 seconds to a minute. Sometimes it doesn't come out of it and I have to do a hard reset. Sometimes my video wigs out, and gives me a driver error saying that it is stuck in a loop or something and I need to reboot, though that's only happened a couple times. I would think this is a driver issue, but I haven't been able to find anyone else having similar problems. This started on a fresh install of XP Pro, and I've tried a few different catalyst drivers (completely removing the previous ones) from 8.9 to 8.12 and they all do the same thing. If I just stay in game I can play fine for hours, everything looks and runs great. I've tried Fallout 3, WoW, L4D, Mass Effect and they all do the same thing. This also happens when I'm playing in fullscreen and change any ingame video settings, though it usually doesn't crash afterwards, it just takes a long time.

2) If I play WoW in windowed mode I can change settings and resolution, do whatever I want in the background etc. fine, but it seems to be capping me at 20 fps for some reason. I have no idea what's causing that either.

So I've tried different drivers, it's not overheating (stays below 55c under load usually), and my PSU should be fine, I only have 1 hard drive and a dvd burner. I've fiddled with whatever settings I can think of and that's about the extent of my diagnostic abilities. Does anyone have any suggestions as to what else I can do, or something else that could be causing it?

The rest of my system:
ASUS M3A78 AMD 770 ATX Motherboard
AMD Athlon 64 X2 5600+
Antec Earthwatts 430W PSU
G.SKILL 4GB (2 x 2GB) PC6400
Seagate Barracuda 250gb SATA HD
Anonymous
December 21, 2008 5:35:05 PM

Here's the blue screen error:

"The problem seems to be caused by the following file: ati2dvag

The device driver got stuck in an infinte loop. This is usually a problem with the device itself or with the device driver programming the hardware incorrectly.

***Stop: 0X000000EA (0X8A34AC90, 0XBA4DFBC, 0X00000001)"

So is the card itself defective, or is it a driver issue?
m
0
l
December 22, 2008 8:44:10 AM

did you used to have an nvidia card before the 4830?

if so do a full uninstallation of all drivers / ati software / nvidia software, restart and boot into safe mode, use drive sweeper to clean out any last bits of fluff, restart and boot into normal windows and reinstall the ati drivers.

also look at cooling, use gpu-z to monitor the temperatures of your card, is it getting hot (over 50-60c) ? can you take the side of the case off and run the game to see if it still crashes.
m
0
l
Related resources
December 30, 2008 12:36:14 PM

My Force3D 4870 1Gb suffers from freezes in Gears of War and Far Cry 2. I don't know what to do. If you solved your problem olease let me know the fix.
Specs are:
Intel E 8400 cooled by ASUS Triton
Gigabyte P45
4 X 1 Gb Kingmax DDR3 1333
Gigabyte Odin Pro PSU 800 Wt
Force 3D 4870 1Gb
2 X 250 Gb RAID0 WD Caviar Black
2 X ASUS 20x DVD-RW
Gigbyte Isolo case
Catalyst 8.12-Vista 64
No overclocking
m
0
l
January 1, 2009 7:50:36 PM

Ordered same system as you have on tuesday and got it already on wednesday and built it then.
Now on thursday installed L4D and it does same thing to me when I alt tab. Freezes about 30sec when I can come back to game. Resolution changes I haven't tried yet in the game, only before I start the game.

About 5 times have done the alt tab thing, but it havent crashed yet:p 

Well that 30sec delay isn't that bad thing and if you dont alt tab, then there is no worries:) 

But would this delay have something to do with the motherboard+ati 4830 combination? Dunno.

ASUS M3A78 AMD 770 ATX Motherboard
AMD Athlon 64 X2 5600+
ASUS HD4830 512mb
2x2gb Kingston 6400 DDR2 CL6
500gb SATA2/SATA300
Vista Ultimate 64-bit
m
0
l
January 3, 2009 11:15:09 PM

OK, a little bit digging gave me this result: ATI sucks...

Have to wait catalyst 8.13 or something like that. Lots of these kind of problems we had with all 4800 series.

m
0
l
January 3, 2009 11:42:50 PM

god the ppl that cant even install drivers right and blame it on ati make me sick
m
0
l
January 4, 2009 11:08:48 PM

U are right:D  catalyst 8.12 solved the problem. Seemed that it was good not to believe others problems with newest drivers.
m
0
l
!