Sign in with
Sign up | Sign in
Your question

RocketRAID 2320 screws up certain WD drives

Last response: in Storage
Share
May 7, 2010 4:22:45 PM

Edit: After much investigation it appears that this indeed is a known problem with RocketRAID 2320 and certain WD drives. I don't know if it extends to other HighPoint controller cards. Basically if you ever initialized an affected drive on this particular controller, it can't ever be used again with other controllers, so please think carefully if you have a similar setup.

I had 4 WD 750G SATA disks in a JBOD array running on a RocketRAID 2320 in XP. I wanted to use the disks elsewhere so I deleted the array using the 2320's interface, then disconnected them from the card. However when I connected them to other PCs, either via a USB dock or directly to the motherboard's SATA controller, Windows or its install CD cannot detect the disks. Apparently having them in the JBOD did something to them that makes only the 2320 able to read them properly. Below is what I've tried so far:

1. Disks show up in BIOS when connected to the motherboard's own controller, but multiple copies of XP and Win 7 installer DVDs as well as the OS cannot see them. Also tried it on different machines too. WD's Data Life Guard utility can see the disks and detects nothing wrong. I cannot format with the utility though, only write 0s.

2. When connected back to the 2320, my only option is to put them in an array. There's no option to "un-initialize" or re-initialize or format through the 2320's own interface. To make them visible to Windows they HAVE to be in an array, even as an 1-disk JBOD array. I want to use them away from the 2320 so this doesn't help anything.

3. If I do put a disk in a 1-disk JBOD array, Windows can see it and format it in NTFS. Of course this disk still cannot be used off of the 2320 due to the JBOD stuff underneath the NTFS.

4. If a disk that's formatted elsewhere FIRST is connected to the 2320, it treats it as a legacy drive and exposes it to Windows without requiring it to be part of an array.

I've read stories where people are able to take an entire RAID array off of the 2320 and restore it using another RAID controller, so maybe the 2320's implementation of JBOD is to blame? All I want to do is to use the disks like normal disks again, without having to connect them to the 2320. I'm about to try a Linux live CD next.

Thanks for any advice.

Edit: Using the latest 2320 Windows driver and web interface. Firmware perhaps not the latest, but within the past year.

Edit 2: Discovered this gem from Newegg reviews. :ouch: 
Quote:
It will eat some WD drives and you'll have to RMA them if you ever want to use them with another controller this from Highpoint tech support which is not very good BTW. At this point I can't trust this controller with my very important files.


I hope there's a workaround...had 8 WD drives hooked up to it.
May 28, 2010 1:38:13 AM

Hello. Thank you for your post. I found it googling to figure out why I couldn't re-initialize my WD disks after using them with a Highpoint controller. Your post sent me in the right direction.

I did find a solution. Before disconnecting from the Highpoint controller, you must reconfigure the WD drives into a RAID0 array. Then disconnect, and then connect to the new controller and reconfigure.

For me, this allowed the new controller to recognize the drives and reconfigure them.

Best of luck.

Lacey
m
0
l
!