Sign in with
Sign up | Sign in
Your question

9800GTX+ just beeps

Last response: in Graphics & Displays
Share
December 22, 2008 10:15:03 AM

I've got a HP Pavillion a6582l and it comes with a Geforce 9300GE. That works fine. I just bought an Inno3d Geforce 9800GTX+ and it just continuously beeps.

* With old card - fine
* With no card - no beeps
* With 9800GTX+ - Long stream of continuous beeps, fans are on, everything seems ok.

I've connected up the power, and plugged it in firmly. One thought occurring to me is it could be PSU related (not enough power). I upgraded from 300W to 550W PSU but still the same symptoms so it must be something else. Any ideas?

Cheers,

Ryan

More about : 9800gtx beeps

December 22, 2008 10:33:22 AM

PCIE is -firmly- connected?
December 22, 2008 10:37:54 AM

Very firmly, tried several times to make sure, and yes it's firmly connected. Not in the least wobbly or anything (though it's a pig to get in, not much space in this case).
Related resources
December 22, 2008 10:38:38 AM

Just a quickie.. would the mobo being a PCI Express x16 one make a difference?
December 22, 2008 10:45:56 AM

I had that prblem once, and it was because i forgot to plug it directly to the PSU, and i quickly realised. maybe the 550W still not enough
December 22, 2008 10:45:56 AM

supertonic said:
Just a quickie.. would the mobo being a PCI Express x16 one make a difference?


No, PCI-e 2.0 is backwards compatable. It seems likely that you simply have gotten a defective card. With that said the 300W PSU was surely inadequate for the card.
December 22, 2008 11:02:37 AM

Yeah I worked out the 300 was inadequate after some digging around. Will go for a swap and see if I get better luck. Thanks to all who have helped, you've hopefully saved me some headaches!
!