Sign in with
Sign up | Sign in
Your question

Raid 0 Stripe Recovery

Last response: in Storage
Share
May 9, 2010 2:37:13 AM

just wanted to Start over and Get a thread going to see anyone has any Knowledge about how to recover from a Virtual Raid 0 Linux
base system.
i know i should not keep doc that is very important. all i been getting is that im screwed. and i feel that there's always a solution with out spending $3000 to send them out. any help will be great guys.

The Drives Work fine they are samsung 2 500gbs.
It was on a D-link DNS323

this is the list i tried

#1
tried every software program that Said reaid0 recovery
#2
Installed them back in the d-link, it says ( Please Format )
#3
installed them on my windows pc. i can see the drives but it wants me to format them





this is my next steps on recovery

#1
not to sure on how Hardware Raid controller would react on them
3ware 9650SE-4LPML KIT PCI Express Lanes: 4 SATA II Controller Card??

#2
Format them back to raid0 and Have a program find them like Quick Recovery. i have done this when one of my friends format there drives and i can recover his Files but not to sure on Raid0?

#3
Thinking of something

More about : raid stripe recovery

a c 415 G Storage
May 9, 2010 3:56:50 AM

From some of sub mesa's posts I understand that the Ubuntu LiveCD automatically loads a RAID recovery driver that should let you access individual drives which were formerly part of a RAID set.
May 9, 2010 2:07:40 PM

yeah i have done that with that program, seems like it works up to that point to only seeing the drives but cant see anything in them
Related resources
a c 126 G Storage
May 9, 2010 6:15:21 PM

Perhaps you'd like to contact me directly via email. If Ubuntu does not work automatically, we can perform the procedure manually. Due to this being more complicated, it would be much easier if i could login over the internet on your (test) system with the two drives attached. This procedure is completely safe - it does not write a single byte to the drives containing your data.

If the data is somehow damaged, it is possible to write the contents to a normal single drive that is at least as big as the RAID0 array. So if you have 2x500GB disks in RAID0, you would need at least a 1000GB drive so it can contain all data. After this procedure, you can use any windows recovery program to recover the NTFS filesystem. It would be like you never used RAID0; so the advantage here is getting rid of RAID0 so file recovery is easier and works with more programs.

If you feel that's a good idea, you can contact me on sub.mesa >at< gmail. Please give me as much information as possible.

I would likely propose something like:
1) disconnect RAID disks
2) insert new/temporary system disk to install FreeBSD to
3) use my online guide to install FreeBSD to the system disk
4) set up SSH access both on FreeBSD and on your router
5) reboot with RAID disks attached
6) allow me to login with root access
7) watch me analyse your RAID and apply software RAID to discover proper setting
8) either recover data directly or write the contents of the RAID to another (large) drive, depending on whether NTFS is damaged or not.

Hope this helps.
June 14, 2011 5:58:47 AM

My motherboard failed, and now I am trying to recover my data from the RAID0 configuration that I had that consisted of 2 500GB SATA hard drives. It was configured using the on-board RAID controller (AMD, SB700) on a Gigabyte MB. I was running Windows 7, and the RAID0 array was formatted as 3 NTFS partitions (OS, Apps, Data).

I took the 2 HDs and installed them in a different computer (with RAID disabled), and booted Ubuntu-Live. From some discussions, I read I was hoping that Ubuntu would automatically recognize the RAID, however I didn't have this luck. The two hard drives show up in the Disk Utility application as Healthy and I've attached the screen shots for further analysis.

Also, I tried to manually use mdadm to detect the array, but no luck there. Here's the log from that:

ubuntu@ubuntu:/$ sudo mdadm --assemble --scan
mdadm: No arrays found in config file or automatically
ubuntu@ubuntu:/$ sudo mdadm --examine /dev/sda
mdadm: No md superblock detected on /dev/sda.
ubuntu@ubuntu:/$ sudo mdadm --examine /dev/sda1
mdadm: No md superblock detected on /dev/sda1.
ubuntu@ubuntu:/$ sudo mdadm --examine /dev/sdb
mdadm: No md superblock detected on /dev/sdb.
ubuntu@ubuntu:/$ sudo mdadm --examine /dev/sdb1
mdadm: cannot open /dev/sdb1: No such file or directory
ubuntu@ubuntu:/$

Right now, I'm out of ideas of what to try next. I would appreciate it any help with this, as I'm really desperate to recover the data on this drive.
a c 84 G Storage
June 14, 2011 3:59:28 PM

RAID0 failure with no backups = lost data. Since each drive only holds half the file system, a failure with either one means all the data is unreadable. And the more you mess with the drives trying to get to the data, the greater chance you have of just making it worse.

Need to bring it to a recovery pro to restore things it looks like.
!