Crysis Problems W/ Two HD4850 Crossfire

So i just got this new computer about a week ago. I went out and bought Crysis and Crysis Warhead because i though my PC would run them well. To my surprise they dont. I get about 15-25 FPS on average on Crysis.

Specs-

CPU: AMD Phenom X4 9650 Quad-Core CPU w/ HyperTransport Technology
MOTHERBOARD: Biostar TA790GX A2
MEMORY: 2GB (2x1GB) PC6400 DDR2/800 Dual Channel Memory
GFX Cards: Two ATI Radeon HD 4850 PCI-E 16X 512MB Video Card W/ Crossfire

Like i said i get a low FPS for this system, and any help will be appreciated.
35 answers Last reply
More about crysis problems hd4850 crossfire
  1. what resolution do u use.....u might need more ram..2gb isnt a lot for crysis especially if running it on high(er) details..get atleast 4gb and be sure to have the latest graphics drivers installed from ati's website..oh and by the way .........try overclocking that processor since your motherboard is a nice overclocker
  2. I usually run at 1280x1020. And do you have a nice overclock Tutorial for me, i haven't overclocked before. And the latest drivers suck lol.
  3. Doesn't the latest driver from ATI have Xfire problems?

    http://www.theinquirer.net/inquirer/news/135/1050135/catalyst-breaks-vista-crossfire
  4. Yes it does. That's why i don't use those drivers anymore. But on 8.12 crysis was even worse for me.
  5. Ok one more time.........CRYSIS games are not set up to run crossfire or sli...........They will only run on one game.......Blame the game manufacture for this.......they are not optimzied for this setup........K
  6. i would get 2gb more ram, as well as what jackieboy said.
  7. I run dual 4850's and have crysis and crysis warhead. Jackieboy was mostly correct. I've played both games with and without crossfire enabled. With the original Crysis there was no benefit from having crossfire enabled, the framerate difference when I benchmarked with and without where within 2 frames of each other. Crysis warhead was slightly more optimized. I noticed a slight benefit with crossfire when things got EXTREMELY busy on the screen (I.E. the big finale at the end). Other then that crossifre didnt seem to benefit as much.

    One thing that will definitely help is upgrading your ram, 4 gigs should be a minimum for serious gaming.

    You also didnt mention which operating system you're using. If using a 32 bit operating system you might want to think about going 64 bit so you can use atleast 4 gigs of memory or more....
  8. I am on Vista 32 bit. Is it really worth going to 64 bit? If it is i will go over.
  9. 2gb on Vista while gaming just isn't enough for serious gaming like Crysis.

    Also, what were the settings you got Crysis on? 'Cause you won't be able to run Ultra high smooth anyways, hehe.
  10. If anyone has vista.....you need at least 4 gigs of memory....vista just is too slow without it much less playing games.........I have 64bit and it works just great......however I don't think its worth switching over to it if you already have 32bit......I see no benefit at all.......I just happen to get a copy of 64 bit for free so hey I didn't complain.
  11. If you have 32-bit you can switch over to 64-bit for the price of MS mailing the DVD out to you.
  12. Well on high settings i get about 15-25 FPS and on Med i get about 25-35. I know my computer should run more smooth on High and that's why this is pissing me off. Also by chance does anyone know when 9.1 ATI Drivers are coming out?
  13. Your processor is limiting you as well.

    You need to lower you settings -quality and AA. Use "No AA" filtering.

    If you got the retail version of Vista, it comes with 64bit on the DVD.

    Crysis is a beast. High end systems have trouble playing the game. You have a mid-low range gaming system. The crossfired cards are a little overkill for the CPU, especially for the resolution that you are using. I'm not sure about AMD's chipsets, but I imagine that a $100 dollar motherboard is not capable of running two cards at 16x speeds. You might actually gain some performance in Crysis by removing one of the cards so that the other can run in 16x mode. (I am talking out my ass here since I am not familiar with the AMD technology, but it is a suggestion that might work. Or it might not, but won't hurt)

    Is crossfire working properly?
  14. SP3CIALAG3NTBOB said:
    Well on high settings i get about 15-25 FPS and on Med i get about 25-35. I know my computer should run more smooth on High and that's why this is pissing me off. Also by chance does anyone know when 9.1 ATI Drivers are coming out?


    No, just no.

    You won't manage to get a higher FPS with 2GB of RAM. You're actually surprising me with an FPS like that.

    Let me explain you something,

    Vista itself uses 1GB of your RAM already, while running normally (no applications open).
    That means you've got 1GB left to run Crysis with. And that's not enough.
  15. Is it me or am I not able to edit messages?

    If you got the retail version of Vista, it comes with 64bit on the DVD.
    Where did you get that from?!

    If you buy 32bit, that means you'll only get 32bit, they won't give you a 64bit for free with that..
  16. xfire dont work that good on crysis
  17. I get average of 55fps in Crysis with a single HD4850 on Dual Core..
  18. meodowla said:
    I get average of 55fps in Crysis with a single HD4850 on Dual Core..

    You made me smile :).
  19. double +1 on the RAM. You need more than 2GB for Warhead. Vista 32 on my system uses anywhere from 500-700MB of ram alone. Warhead uses well over 1.5GB....right there you already have an issue. Pop in 4GB of ram even if you do have a 32 bit OS. It will help trust us.

    Also, don't expect to match people's FPS with an AMD CPU running at stock speeds. They don't do as well in gaming as Intel does.

    Also, double check with your ATI xfire settings to show the xfire symbol when it is working. If you don't see it in Crysis then that is a problem too. Make sure Catalyst AI is enabled. Also, don't use AA in the CCC if you are. It doesn't do anything but reduce your FPS.

    Edit: You can also disable xfire and compare your FPS of one GPU to tell it if is working or not. The more I think about it, you might not be utilizing xfire for some reason or your other problem is that you didn't fully uninstall your drivers before updating them. I would grab the 8.12 hotfix for 4850 xfire and install that after removing the drivers from your system. Hopefully some of this helps you out.
  20. meodowla said:
    I get average of 55fps in Crysis with a single HD4850 on Dual Core..


    Yeah I can get like 80FPS if I turn it on low settings and disable AA. Your FPS are meaningless if you don't tell us what resolution and settings you run at.
  21. meodowla said:
    I get average of 55fps in Crysis with a single HD4850 on Dual Core..


    we're 3 months away from april.
  22. as said above your 55fps means little without more info. If its on High or very high then you must have the best 4850 ever made, better than my 2 4870's. Also the person above who said you only get one version of vista is wrong, if you buy OEM than you have to choose between the 32 and 64bit but if you buy retail you get them both.
  23. crysis loves a fast CPU and thats something the X4 9650 can only dream of being
  24. jackieboy said:
    Ok one more time.........CRYSIS games are not set up to run crossfire or sli...........They will only run on one game.......Blame the game manufacture for this.......they are not optimzied for this setup........K


    my ass... you WILL notice a difference in SLI, crossfire maybe not so much. either way, you should not be getting such crappy FPS. i would blame your CPU bro, its REALLY not a fast cpu by ANY means. one things thats funny is you had to mention w/ hyper transport technology. :lol: :lol: :lol: :lol: guess that hyper transport aint helpin too much when you need it eh? :kaola:
  25. SP3CIALAG3NTBOB said:
    I usually run at 1280x1020. And do you have a nice overclock Tutorial for me, i haven't overclocked before. And the latest drivers suck lol.


    How did nobody notice this. He's running 2x 4850's for a res of 1280x1020. That will cause a larger bottleneck on the cpu than the cards. Even though its likely that they are not working correctly anyway.

    Also what kind of detail level are you trying to run? Ignore all the idiots on the forums that say they can run maxed out everything BS have you just tried lowering the detail level.
  26. I've got a MSI K9A2 790fx board running a quad 9850 with two sapphire hd 4850's and I have the same problem with Crysis. I'm running windows 7 x86 build 7000 with 4 gigs of Corsair 1066Mhz memory at 5-5-5-15 timings. The CPU is overclocked to 2.8Ghz and it still seems like I'm CPU limited. Every time I bump up the CPU a little my Crysis fps go up significantly. Running 8.561.3.0 catalyst driver with the crossfire hotfix. My setup screams on everything else. COD5 I average 55 fps on a 1080p big screen with everything cranked up. It's a sweet rig for most games... well, essentially everything BUT crysis.

    Bottom line is Crysis and ATI just don't play nice together. I wouldn't over analyze it too much. Besides, Crysis isn't all that. I'd take BF2 over that crap any day.
  27. SP3CIALAG3NTBOB said:
    So i just got this new computer about a week ago. I went out and bought Crysis and Crysis Warhead because i though my PC would run them well. To my surprise they dont. I get about 15-25 FPS on average on Crysis.

    Specs-

    CPU: AMD Phenom X4 9650 Quad-Core CPU w/ HyperTransport Technology
    MOTHERBOARD: Biostar TA790GX A2
    MEMORY: 2GB (2x1GB) PC6400 DDR2/800 Dual Channel Memory
    GFX Cards: Two ATI Radeon HD 4850 PCI-E 16X 512MB Video Card W/ Crossfire

    Like i said i get a low FPS for this system, and any help will be appreciated.


    What resolution are you running? I ran Crysis at 1920x1080 on all high settings with my 4850 X2 (before I got my TriFire working) with Catalyst 8.12 hotfix (huge performance gains in Crossfire). Crossfire DEFINITELY scales. I don't want to be a bearer of bad news, but your processor is the weak link. Especially if you attempt anything in the Very High Settings category.

    The game Crysis is a perfect example of a game that is amazing, but under utilizes the technology running it. It only supports two cores in game play, which would explain why your Phenom having a hard time keeping your 2 4850's feed with data. Crysis only allowing two cores to run the physics, AI, sounds, etc... while managing your two video cards. I ran my 1 4850 by itself and saw great frame rates boost at 1680 x 1050 (All high settings) when I moved to a Phenom 2 @ 3.53 Ghz (IMC/L3 is overclocked to 2.28) compared to when I had a 3.2 Ghz Athlon 64 (which is probably faster than what you are running as far a Crysis is concerned... unless you are around 3GHz). It's a sad result of poor programming. Play Far Cry 2 (very multi-core) and your computer will be singing a different tune all together.

    One thing you may want to try. If you are running the game in Directx 10, there is a substantial frame rate hit that takes place compared to running it in Directx 9. The difference in image quality is not very visible to some actually playing the game and not just comparing screenshots. Setting the game to run in Directx 9 is guaranteed to give you a noticeable boost in frame rate.
  28. SpinachEater said:
    double +1 on the RAM. You need more than 2GB for Warhead. Vista 32 on my system uses anywhere from 500-700MB of ram alone. Warhead uses well over 1.5GB....right there you already have an issue. Pop in 4GB of ram even if you do have a 32 bit OS. It will help trust us.

    Also, don't expect to match people's FPS with an AMD CPU running at stock speeds. They don't do as well in gaming as Intel does.

    Also, double check with your ATI xfire settings to show the xfire symbol when it is working. If you don't see it in Crysis then that is a problem too. Make sure Catalyst AI is enabled. Also, don't use AA in the CCC if you are. It doesn't do anything but reduce your FPS.

    Edit: You can also disable xfire and compare your FPS of one GPU to tell it if is working or not. The more I think about it, you might not be utilizing xfire for some reason or your other problem is that you didn't fully uninstall your drivers before updating them. I would grab the 8.12 hotfix for 4850 xfire and install that after removing the drivers from your system. Hopefully some of this helps you out.
  29. SpinachEater said:
    double +1 on the RAM. You need more than 2GB for Warhead. Vista 32 on my system uses anywhere from 500-700MB of ram alone. Warhead uses well over 1.5GB....right there you already have an issue. Pop in 4GB of ram even if you do have a 32 bit OS. It will help trust us.

    Also, don't expect to match people's FPS with an AMD CPU running at stock speeds. They don't do as well in gaming as Intel does.

    Also, double check with your ATI xfire settings to show the xfire symbol when it is working. If you don't see it in Crysis then that is a problem too. Make sure Catalyst AI is enabled. Also, don't use AA in the CCC if you are. It doesn't do anything but reduce your FPS.

    Edit: You can also disable xfire and compare your FPS of one GPU to tell it if is working or not. The more I think about it, you might not be utilizing xfire for some reason or your other problem is that you didn't fully uninstall your drivers before updating them. I would grab the 8.12 hotfix for 4850 xfire and install that after removing the drivers from your system. Hopefully some of this helps you out.


    How do you enable Catalyst AI. I have a 4870X2 and a Intel Q6600 cpu clocked to 3,5GHz and i ran Crysis Warhead on Enthusiast settings on 1680x1050 and i got like 30fps Avg

    I don't get it... I had an avg of 35 fps when i had a 4870. I got Windows Xp x32 with 4gigs of ram and the catalyst version is 8.12
  30. Oh.. make that a 4850X2 instead of a 4870X2...
  31. Under 3D settings in CCC you should find the Catalyst A.I. option. Try turning it on and leaving the slider on the left side to whatever that setting is.

    For Crysis I am not sure how much better the 4850x2 is supposed to be in comparison to the 4870. I haven't looked at any current 4850x2 benchmarks in a while. I wouldn't be surprised if normally comes in around the 4870 in Crysis.
  32. SpinachEater said:
    Under 3D settings in CCC you should find the Catalyst A.I. option. Try turning it on and leaving the slider on the left side to whatever that setting is.

    For Crysis I am not sure how much better the 4850x2 is supposed to be in comparison to the 4870. I haven't looked at any current 4850x2 benchmarks in a while. I wouldn't be surprised if normally comes in around the 4870 in Crysis.

    But i actually gain like 1-2 fps if i disable the crossfire so i think i have a problem but it can be a problem with the catalyst version so i'll just have to wait for the new one and compare when i install it
  33. exmaxinz said:
    But i actually gain like 1-2 fps if i disable the crossfire so i think i have a problem but it can be a problem with the catalyst version so i'll just have to wait for the new one and compare when i install it


    Its your processor that is limiting the scaling. Look at my last post and you will understand why. You simply need WAY more MHz two make 2 processors core push that setup. My frame rates are doing just fine with two 4850s...
  34. exmaxinz said:
    How do you enable Catalyst AI. I have a 4870X2 and a Intel Q6600 cpu clocked to 3,5GHz and i ran Crysis Warhead on Enthusiast settings on 1680x1050 and i got like 30fps Avg

    I don't get it... I had an avg of 35 fps when i had a 4870. I got Windows Xp x32 with 4gigs of ram and the catalyst version is 8.12


    O yeah, one more thing. When you were in XP, you were playing it in Directx 9 mode, now in Vista you are playing in Directx 10 mode (WAY slower). Put in Direct 9 mode (google it), and you will free up the processor power you need to efficiently keep your two cards fed. As of right now, your processor is doesn't have enough processor power left over to your two cards (the extra overhead of two cards combined with the additional stress of Directx 10 is actually bringing down the performance when crossfire is enabled).

    The increase in framerates when running Crysis in directx9, in your case, will be majorly attributed to the extra processor power freed up, thus giving it more leverage to push your graphics cards.

    If you NEED directx 10 mode ... get a Core2 Duo and overclock it to 4.5 GHz. (Why a Core2 Duo... read my post from two times ago!)
  35. Antman56 said:
    O yeah, one more thing. When you were in XP, you were playing it in Directx 9 mode, now in Vista you are playing in Directx 10 mode (WAY slower). Put in Direct 9 mode (google it), and you will free up the processor power you need to efficiently keep your two cards fed. As of right now, your processor is doesn't have enough processor power left over to your two cards (the extra overhead of two cards combined with the additional stress of Directx 10 is actually bringing down the performance when crossfire is enabled).

    The increase in framerates when running Crysis in directx9, in your case, will be majorly attributed to the extra processor power freed up, thus giving it more leverage to push your graphics cards.

    If you NEED directx 10 mode ... get a Core2 Duo and overclock it to 4.5 GHz. (Why a Core2 Duo... read my post from two times ago!)

    I don't use vista and i've clocked my cpu to 3,5GHz so that should be enough. I know that crysis doesn't support crossfire in most cases. My card gives me like 80 fps in far cry 2 max settings 1680x1050
Ask a new question

Read More

Radeon Crysis Graphics