Sign in with
Sign up | Sign in
Your question

1TB Sata Media HDD: No Longer Accessible

Last response: in Storage
Share
May 11, 2010 10:02:17 PM

Long time viewer first time poster. Here is the long story as short as I can make it.

I have an HTPC w/ WinXP SP3 that I have run mediaportal on for about a year. I have 2 Sata HDD's in the system. 1 drive which is the OS HDD and the other 1TB drive is a Media HDD and it was formatted while running WinXP. It has been functioning correctly and is full of media.

I recently tried out Win7 for a few months on a partition that I created on the OS HDD. After the Win7 trial ran out I decided to go ahead and format the entire OS HDD and reinstalled WinXP and mediaportal. During this time I made no changes to the other Media HDD which contained movies, pictures, music etc.

Once XP was reinstalled and updated etc the Media HDD showed in Explorer and obviously Disk Management, but is not accessible. When trying to access the HDD explorer states that the drive needs to be formatted. The drive is basically acting as if it has never been formatted before, but it is full of media so it is obivously formatted. The drive is almost new and nothing changed in my setup in my PC hardware. The only change was I formatted the OS HDD and reinstalled WinXP to the exact state that is was previously. The Media HDD worked in both Win7 and WinXp previously as I had a dual boot setup.

I have tried changing Sata chennels etc to try and get the drive to be accesible although I beleive this is not the problem since bios, explorer, and disk management recognize the drive and assign it a drive letter.

I also purchased a USB enclosure and when connected through this setup I get the same result it shows in explorer, but states it needs to be formatted.

I have also used Linux Ubuntu Live CD to try and access the drive it does not show up at all in Linux using Sata or USB connection. I am not proficient enough in Linux to troubleshoot that any farther.

Is it possible for a drive to lose its formatted file structure and need to be formatted again. It is just such a coincidence that it happened at the same time that I reinstalled WinXP on the OS HDD though. I beleive if I format the drive it would work pefectly, but I just do not want to lose all that media.

What are my options? Thanks.
a b G Storage
May 12, 2010 9:38:19 AM

this wouldnt be an issue if you backed up your data......

test your hardware and report back - got solutions for everything *DEPENDING* on the condition of your hardware etc
m
0
l
May 12, 2010 5:43:27 PM

Ubuntu should have default NTFS read support (no write without add-ins) depending on which version you're running. If it doesn't you would have to download the support. If you are not that familiar with linux this is probably going to be a headache or solid learning experience depending on your approach. Probably not going to be a quick solution though.

Is the partition showing up at all or only the drive itself? I'm assuming it isn't or you should be able to run a chkdsk on it. You can try running a recovery tool on the drive like Recuva (free from Piriform) to see if the files are actually still on the drive but you will need space on another drive to recover them to. Then it can point to a partition table error. There are other tools out there just be careful about writing changes.

Reinstalling Win7 trial to see if its readable under that OS may help narrow it down as well.
m
0
l
Anonymous
a b G Storage
May 22, 2010 6:17:46 AM

in simple words, this problem occurred as the prev Win Xp knew the association with the other 1TB media drive. when u did a complete format of the OS HDD, it lost all that information about the 1TB media disk. It is like a stranger to the OS disk now. To solve this problem try Atola Partition Find and Mount which comes for free and is also easy to use. Get it at http://findandmount.com/.

just scan for the partition and then recover it.

else u may also try doing it with the Win Xp OS cd. just boot it up with the XP installation disc. After the initial drivers load up, go to RECOVERY PARTITION (and not Windows installation). Type fixboot and fixmbr and then restart. the other drive may work properly now.

else just disconnect the 1TB HDD from the motherboard and reconnect it again. it will auto detect a new hardware and will setup the drive for u.
m
0
l
!