Sign in with
Sign up | Sign in
Your question

How do you know if your crossfire is working

Last response: in Graphics & Displays
Share
December 29, 2008 4:40:58 PM

This might seem like a dumb question, but...... I just crossfired my computer with slightly different cards and I can not tell if it is working or not performance wise. Under the ccc it says that I am crossfired. I have a amd dual core 6400+ 3.2 ghz per core, 2 gigs ram, 3870x2(now), vista64home.
I could max out every game I owned except crysis before. I don't see any improvement in crysis and I have read that that is not unusual. It just seems weird that I don't notice anything. I downloaded 3d mark advantage and got a 7700 score. This is right up with people that have a single 3870 and not 2-3870's. I downloaded gpu-z but I don't really understand the results that gives me. It almost seems that they see that I have 2 cards but they are running independtly and not crossfired. One other thing that is weird that I found while looking at the ati website was that they showed the monitor plugs being split and put into both cards but said that it depended on what cards were being crossfired and provided no other info. I guess I should call ati and try and get customer service, but it just seems like I will be waiting on the phone for a long time to hear them tell me that I need to call my motherboard manufacturer or something. It is curious nowadays with computers how customer service likes to pass the buck around.

More about : crossfire working

December 29, 2008 7:01:55 PM

GPUz will tell you at the bottom if they are crossfired or not. It will say "disabled" if they are not.

You should reinstall the newest catalyst drivers.

What motherboard do you have?
December 29, 2008 7:02:51 PM

msi k9a2 cf this is my motherboard
Related resources
December 29, 2008 7:06:06 PM

on gpuz it says enabled 2-gpus (unsure on vista)
December 29, 2008 7:06:16 PM

I have that motherboard too. Unfortunately I only have a single 3870, and right now it is running WinXP, so I can't run any Vantage comparisons.

***EDIT** You beat me to it. What does GPUz say? Have you tried the latest version? http://www.techpowerup.com/downloads/SysInfo/GPU-Z/DTI
December 29, 2008 7:10:50 PM

Crossfire really doesn't do much at lower resolutions but crank up the resoulution and you should see an improvement over a single card. What is your current resoultion set at?
December 29, 2008 7:12:39 PM

1680x1050 this is my monitors max
December 29, 2008 7:13:07 PM

it didn't help at all for crysis
December 29, 2008 7:14:24 PM

i am currently installing 3dmark06 this should give me a more accurate picture then vantage I have been told
December 29, 2008 7:29:16 PM

Is this Warhead or the first Crysis? I found that Warhead wasn't running xfire on my system but Crysis would for some reason. I noticed the same thing you are...no improvement at all.


Check out my thread from a while back and see if this helps.
http://www.tomshardware.com/forum/257165-33-warhead-xfi...

To enable the xfire icon right click on the CCC tray icon and under your first GPU in xfire settings, check enable icon or what ever it is called. When you run a game, it will have a huge ATI logo in the upper right corner. I was finding that Warhead wasn't displaying it.
December 29, 2008 7:56:39 PM

my mark 11717, it was close to similar crossfired systems.... most similar systems ran at about 14,000.... they might have overclocked there systems though
December 29, 2008 8:11:47 PM

hmm that seems about right.
On my old K9A2 with CF 3870's...

9500 at 2.2ghz 11,000 on 3dmark
9950 at 2.6ghz 14,000 on 3dmark
9950 at 3.0ghz 15,500 on 3dmark

so I'd assume with the slower NB and HT on the x2's that 11,000 would be about right?

On a side note it's going to be CPU limited. I noticed when I switched to a 1GB 4870 with the 9950 @ 3.0 Ghz I got 15,000, and CF with a 2nd 1GB 4870 I got 15,400. Which tells me even the 3870's where CPU limited to some extent (and the 4870's EXTENSIVELY limited).

PW
December 29, 2008 8:12:14 PM

i tried your crossfire logo on crysis and it didn't work. i pressed the ~ button on crysis and noticed there is a bunch of errors accessing files. maybe i should reinstall crysis.
December 29, 2008 8:28:44 PM

I am getting 17020 on 3dmark06 with 2-3870s xfired.

rest of my specs:
e7200 @ 3.8G, 1.33v
GA-EX38-DS4, Rev 1.0, Bios F6a
2x2G patriot pc6400, 2.0v
win xp sp2 32bit.

With a single 3870 and stock cpu clock of 2.5G i get 3dmark06 of 11000.

with my xfire enabled and 3.8G, 1680x1050 4xAA, max AF, i get FPS like this:
Crysis wars - 30FPS+ maxed settings.
Farcry2 - 40 fps + max settings
COD4 - 90 FPS+ max settings
COD5 - 70 fps+ max settings
Teamfortress 2 - 100 fps + max settings

OK. What about you CCC settings. Catalyst AI must be enabled for crossfire to work. Check that. That is the biggest mistake that is made with crossfire. Catalyst AI is not automatically enabled. you must do it manually.

run 3dmark with one card, then run it with both. you should get about 5000 more with 2 cards in 3dmark06.
December 29, 2008 8:41:43 PM

SpinachEater said:
Is this Warhead or the first Crysis? I found that Warhead wasn't running xfire on my system but Crysis would for some reason. I noticed the same thing you are...no improvement at all.


Check out my thread from a while back and see if this helps.
http://www.tomshardware.com/forum/257165-33-warhead-xfi...

To enable the xfire icon right click on the CCC tray icon and under your first GPU in xfire settings, check enable icon or what ever it is called. When you run a game, it will have a huge ATI logo in the upper right corner. I was finding that Warhead wasn't displaying it.


I remember the first post now, it just slipped my mind to check your replies back then. I enaled it and it does work for me in Crysis, Crysis Warhead, Rainbow6 Vegas2, Call of Duty4, and Call of Duty World at War. Doesn't work in FSX and I know Falcon4 doesn't support Crossfire. Haven't had a chance to see if it works in my racing sims. They could have made the icon a little smaller.
December 29, 2008 8:42:46 PM

Oh yeah. forgive me for these questions.

are your crossfire bridges installed? I put both cf bridges on.

are both cards plugged in? are the fans spinning?

does your bios have any cf settings that need enabling?

do you have the correct PCIe slot selected as your primary graphics slot in your bios? In my gigabyte bios i have to select the primary pcie slot.

did you uninstall your old ATI drivers before installing the new ones? always uninstall ATI drivers using the ATI uninstall tool. reboot to safe mode. use driver cleaner to clean all ati drivers and registry inputs. finally delete all the files in your windows prefetch folder.

December 29, 2008 10:25:08 PM

ok 50mg
from the 1st post, i am a little confused about manually turning on the ai. There is a crossfire graphic setting and the crossfire enabled has a check next to it.
from the 2nd post
I only had one bridge so I put it on the link towards the back of the computer, I found info somewhere that said that hooking up both is not required.
both cards are plugged in and fans are spinning according to gpuz, I can not see them both
I have not checked my bios yet. Will do this if it is not too complicated.
I did not uninstall my old drivers. Vista recognized that I had put in another card and downloaded software automatically. CCC all of a sudden recognized the extra card as well and automatically turned on the crossfire for me.
I think that it is time to try a 3dmark with the card disabled and see what the score is......
December 29, 2008 10:48:33 PM

9930 with one card, so only a 1000 more roughly.... something has to be wrong
December 30, 2008 1:47:35 AM

stoner133 said:
I remember the first post now, it just slipped my mind to check your replies back then. I enaled it and it does work for me in Crysis, Crysis Warhead, Rainbow6 Vegas2, Call of Duty4, and Call of Duty World at War. Doesn't work in FSX and I know Falcon4 doesn't support Crossfire. Haven't had a chance to see if it works in my racing sims. They could have made the icon a little smaller.



So you got the symbol with Warhead then? That is interesting. I wonder what the difference is then and why xfire wasn't kicking in on my system. I know man, that icon is so huge. Even 1/4th of that size would be too big. I wish they allowed you to control the size and what corner to put it in.
December 30, 2008 2:05:04 AM

Hey snickers, I would start from scratch and then post your 3DM06 scores for us for a single card and then xfired.

Unistall your drivers completely...go through the add/revome programs and remove CCC. Restart and then delete all ATI files and folders possible and then install drivers 8.12. Also, If you have any NV drivers by chance get rid of those.

December 30, 2008 4:19:15 AM

+1 for all new drivers, 8.12.

I am not talking about enabling crossfire. That is a different setting. I am talking about "Catalyst AI" in the 3D settings of CCC. It must be enabled for crossfire to work. make sure it is not disabled and it should be on the standard setting.

check this pic out of my CAT AI and crossfire.
http://i33.photobucket.com/albums/d68/50_BMG/CatAI.jpg

This may or may not help your issue, but Cat AI must be enabled.

I think the reason a lot of people use 2 crossfire bridges is just in case one goes bad. you may have a bad xfire bridge.
December 30, 2008 5:51:26 AM

50bmg said:
I am getting 17020 on 3dmark06 with 2-3870s xfired.

rest of my specs:
e7200 @ 3.8G, 1.33v
GA-EX38-DS4, Rev 1.0, Bios F6a
2x2G patriot pc6400, 2.0v
win xp sp2 32bit.

With a single 3870 and stock cpu clock of 2.5G i get 3dmark06 of 11000.


I got 12,400 or so in 3DMark06 with the 3870x2, but my "triple cripple's" at stock 2.4. Still running with a 17" CRT.

Hope to see improvements when I get a 24" LCD with my income tax refund. The two definite ways to improve framerates is to game at a higher resolution or to go with a higher CPU clock.

In games, I know I got Crossfire in Oblivion and The Witcher, but not so sure on LOTRO. Thinking of just going over to a 4870 1 gig for the next year to avoid Crossfire issues.

My first $450 GPU last February and my first dual GPU setup and I wasn't overly impressed compared to the next generation's best single GPU performance at a better price.



December 30, 2008 4:10:43 PM

ok where do I start?
First of all, my motherboard manual said that I do not have to enable crossfire for it to work
2. one card on 3dmark 9930, two cards 11717
3. I reinstalled ccc and all of a sudden I could get crysis to give me the xfire logo, it even was on 3dmark
4. 12103 was my score after the reinstall
5. (50 meg) thanks for the pictures. They were helpful. First the one on the left is how my ccc is. It is set to standard. The one on the left is curious though.... there is nothing written inside my box telling me that crossfire has now started, blah, blah. Mine is blank. Also yours says sychmaster after your video card. Mine says ddc. Do you ever screw around with the ati overdrive?
6. (spinach eater) I think that you are correct. I need a complete reinstall of my drivers and ccc. The part that is confusing to me is deleting all the files from ati and nv. I know how to go to control panel and delete ccc but am a little intimidated about the other. I have read about using driver cleaners to get rid of all the drivers... is this what you mean. You shut down your computer. Run it in safe mode. Use a driver cleaner and then reinstall 8.12. I am getting better at doing these things on my computer, but I believe I would need dummy directions to do those things. What driver cleaner works the best and is it free? Safe mode is run in bios?
7.
December 30, 2008 4:23:36 PM

yeah, yipsi. I agree xfire is not worth the money if you are buying new generation gpus. What i do is, i get one gen back or when the prices drop. For example; i got my 3870s in may at $129 ea. last xmas they were $240 ea. I personally never spend money on the newest tech. It will be half price in 6 months and will run any app out for a couple of years. When the 4870's drop below $160 or so, i will probably upgrade to a single 4870. When they drop below $130 i will get a second one and xfire them. Add that with a cheaper cpus that is a good OCer and you can get some good FPS out of games. Lower cpu clocks score much lower on 3dmark06, regardless of number of cores.

Yipsi, if you have an am2+ socket, i would wait on the phenom II. They are supposed to be great OCers. The phenom II is compatible with AM2+ and AM3 sockets. Get a bios update and pop one in. I have read they get 4Ghz with good air cooling.

If you have a 17" monitor dont get a 1G gpu. Get a better cpu. The 3870s are bottlenecked by your cpu. They can push the 24" monitor fine with a good cpu. The 4870 1G would run a 24" much better, but the 3870's will be very nice with a higher cpu. the 4870 would still be greatly bottlenecked with your current cpu. Besides the 4870 1G will be $160 or less in a couple of months.

sorry for getting of topic.

December 30, 2008 4:33:20 PM

snickers1300 said:
..............I have read about using driver cleaners to get rid of all the drivers... is this what you mean. You shut down your computer. Run it in safe mode. Use a driver cleaner and then reinstall 8.12. I am getting better at doing these things on my computer, but I believe I would need dummy directions to do those things. What driver cleaner works the best and is it free? Safe mode is run in bios?
7.


yes, do a driver cleaner.

1. download driver cleaner pro and install: http://downloads.guru3d.com/download.php?det=745

2. Download ATI CCC 8.12. do not install yet.

3. use the ATI uninstall in program files/ATI. Restart.

4. enter safe mode, tap f8 as it is booting up.

5. run driver cleaner pro. Select all the ATI drivers. IT will clean the registry also. no worries. this is safe.

6. go to windows/prefetch. Delete all the files in that folder.

7. restart

8. after restart cancel all new hardware found boxes.

9. execute/run ATI 8.12. complete it and restart.

10. after restart enter CCC enable Xfire, set 3d settings. Make sure Catalyst AI is enabled.

now try 3dmark.
December 31, 2008 3:01:39 PM

12,507
It looks as if that is max right now.
Maybe I'll through a couple more gigs of ram in her and wait for the 4870's to come down in price.
Thanks to everyone who helped I really appreciate it.
!