Sign in with
Sign up | Sign in
Your question

Brand New 4870 Issues

Last response: in Graphics & Displays
Share
December 30, 2008 9:17:26 PM

EDIT: Sorry, I forgot to put this in the ATI subforum.

Hey everyone, I got myself a brand new Sapphire 4870 1GB from Newegg, and quite frankly, it sucks. Something is obviously wrong. Probably me.

Anyway, I used to have an 8800GTS 320MB. I uninstalled the ForceWare drivers, rebooted into safe mode, ran driver sweeper, then took out the old card.

Then I installed the 4870 and installed Catalyst w/Control Center v8.12. However, I'm having some issues.

1. Anti-Aliasing is not showing up in Oblivion. It should be 24x samples according to CCC.

2. Same FPS as the old 8800GTS 320.

3. BOSDed once.

I know my system is bottlenecking it, but it shouldn't be THAT much. Here's the rest of the system:

Athlon X2 5200+ 2.6GHz
2GB DDR2
ASUS M2N4-SLI nForce 4

EDIT2: Also, I'm playing @ 1680x1050.

More about : brand 4870 issues

a c 105 U Graphics card
December 30, 2008 9:28:11 PM

I don't know if it applies or not.............. There are problems with the 8.12 drivers. Try the 8.11's until something new come along.
December 30, 2008 9:44:32 PM

Thanks, I'll try that now.
Related resources
December 30, 2008 10:23:11 PM

sebastian7 said:
EDIT: Sorry, I forgot to put this in the ATI subforum.

Hey everyone, I got myself a brand new Sapphire 4870 1GB from Newegg, and quite frankly, it sucks. Something is obviously wrong. Probably me.

Anyway, I used to have an 8800GTS 320MB. I uninstalled the ForceWare drivers, rebooted into safe mode, ran driver sweeper, then took out the old card.

Then I installed the 4870 and installed Catalyst w/Control Center v8.12. However, I'm having some issues.

1. Anti-Aliasing is not showing up in Oblivion. It should be 24x samples according to CCC.

2. Same FPS as the old 8800GTS 320.

3. BOSDed once.

I know my system is bottlenecking it, but it shouldn't be THAT much. Here's the rest of the system:

Athlon X2 5200+ 2.6GHz
2GB DDR2
ASUS M2N4-SLI nForce 4


Regarding the 24xaa, the drivers need to support 24xaa (shader based aa) in Oblivion (they might not) and first off you need 8xAA selected in game. Try whatever driver version you settle on without CCC. It might be causing some issues on its own. You can download the bare driver from the same page you get the 'full' driver from.
December 30, 2008 10:35:13 PM

Can I just select not to install CCC when I use the package I downloaded?

Also, can you not force AA like you can with Nvidia drivers? Oblivion won't let you use HDR and AA at the same time, so I can't turn on any in-game AA settings.

I installed the 8.11s, but I'm still only getting FPS in the 30s, which is the same as the GTS 320.
December 30, 2008 11:34:41 PM

Nevermind, I went ahead and downloaded 8.11 drivers only. I installed the 8.11 drivers and ATI Tray Tools.

My FPS went to low 40s, but I still can't use AA. I don't know what the deal is. When I use the Max Quality preset with ATI Tray Tools, I can see that Anisotropic filtering is applied, and the overall texture quality is better, but still no Anti-Aliasing. I've read where people have used AA+HDR with Oblivion with 4800 series, so I don't know.

I hope it's not the card, but I may have to give Sapphire a call.
!