Solved

Can't uninstall marvell 61xx driver

Hello,

I was updating my Asus P5Q-E and installed the marvell 61xx raid driver (Marvell 6121 SATA Driver V1.2.0.69 for 32/64bit Windows7) , since I have 2 hds in raid 0 (supported by two orange sata in the motherboard).
But now my system boot time is terrible slow and I can't uninstall Marvel 61xx driver in Programs and Features since the uninstaller says "Can't uninstall driver because OS volume is handled by 61xx driver".

Everything was running ok before I installed this driver. Tried Revo but it didn't work as well.


Please help!!
6 answers Last reply Best Answer
More about uninstall marvell 61xx driver
  1. Back up your data and reinstall your OS...
  2. really?
    isn't there any other solution??
  3. Best answer
    You should be able to roll back the driver from device manager...
  4. thanks r-sky, I will try that and let u know if it works ASAP
  5. Best answer selected by luccha.
  6. It worked perfectly r-sky, thanks a lot!
Ask a new question

Read More

NAS / RAID SATA Storage