Sign in with
Sign up | Sign in
Your question

Fix for HotLib/transport monitor problem - Palm Desktop/Mi..

Last response: in Cell Phones & Smartphones
Share
Anonymous
a b C Monitor
June 29, 2005 7:31:48 PM

Archived from groups: comp.sys.palmtops (More info?)

I solved a problem that was vexing me greatly with the help of a french

language forum archive. I have translated the instructions and am
reposting them here for reference purposes. I hope they will help
someone. I would be tickled if anyone who derives benefit could dash
me an email.

They address problems that give errors like
The Application "Transport Monitor" could not be launched due to a
shared library error:
"B<Transport Monitor><Transport Monitor><HotsynLib.PPC><>"

or

The application "Transport Monitor" could not be launched because of a
shared library error: "h<Transport Monitor><Transport
Monitor><HotSyncLib.PPC><__ct_ _16CTransportRelMacFP18OpaqueT
ransportRefUc>"

For me these problems arose after upgrading to Tiger and when using my
zire 71.

*******************

I solved the same problem (in 10.4, Tiger) by following the directions
on this site:

<http://forum.palmattitude.org/ index.php?showtopic=18882>

Unfortunately, they are in French, so I will translate. Note that this

method is used when everything is screwy and you need to toally reset
your syncing/palm. It will eliminate all of your preferences iSync, as

well as removing all Palm stuff. You will need to reinstall Palm
Desktop when you're done (as well as Missing Sync, -including serial
number - if applicable.)

1. Use Terminal to kill all Palm Processes:
Open /Applications/Utilities/Termin al
maximize the terminal window
type "ps -aux | grep Palm" and hit return
(note for CL newbies - that isn't an L, it is a pipe, usually

found over the Enter Key. Also, don't type the quotes - they are their

for clarity on this page only.)

You will be given a list of running processes that are related to Palm
software. On the far left, you will see your username followed by
Process ID Numbers (PID's) If you Use missing Sync, you will see
"root" followed by a PID

type "kill -9 ### ### ###"
substituting your PID's for each of the ### (I put extra spaces in for
legibility - you only need one between each pair of PID's)

If you use Missing Sync, you will need to kill that PID with
"sudo kill -9 ###"
followed by your password.

Trash All of the Following:
/Applications/Palm/
/Library/Application Support/Palm Desktop
/Library/Application Support/Palm HotSync
/Library/CFMsupport/Palm Conduit Licrary
/Library/Preferences/com.marks pace.missingsync.palmos.plist
/Users/yourname/Library/Prefer ences/
- com.palm.hotsync.plist
- com.palm.PalmDesktopinstaller. plist
- com.palm.PalmDesktopsetup.plis t
- Palm Desktop Info
- com.apple.isync.plist <---THIS ERASES iSYNC
PREFERENCES
- com.markspace.missingsync.palm os.plist

/Users/yourname/Library/Prefer ences/ByHost/
- com.palm.HS.T.PC.0030656cef6a. plist
- com.palm.HS.T.S.0030656cef6a.p list
- com.palm.HS.T.USB.0030656cef6a .plist
/Users/yourname/Library/Docume ntation/Help/
/Users/yourname/Library/Applic ation Support/Palm HotSync
HotSyncManager Help
(****IMPORTANT The next step erases your user data for Palm Desktop -

Photos, Voice recordings, Palm Calendar, etc. If you use Palm desktop,

you should figure out how to back this stuff up before you continue. I

don't know, because I don't use it.)
/Users/yourname/Documents/Palm /

3. Use spotlight to search for "Palm Hotsync" If any folders show up,

throw them out.

4. Empty the trash while holding down the option key.

5. If you use Missing Sync, run the "Uninstaller Installer" in
/Applications/Missing Sync/ - this will uninstall what's left of
Missing Sync.

6. Restart

7. If you want Palm Desktop, reinstall using the latest version:
<http://www.palmone.com/us/supp ort/macintosh/>

Restart

8. Ditto Missing Sync:
<http://www.palmone.com/us/supp ort/macintosh/>

Restart

9. Launch /Applications/Palm/HotSync Manager

10. Create new user.

11. Sync one time.

12. Launch iSync
Devices ->enable palmos syncing
Do what it tells you

13. Launch Missing Sync
double click "iSync Conduit" to enable for this device"
sync with the button on your palm

Hope that helps!
September 11, 2007 1:04:32 PM

Juneappal's fix works. I've googled this for weeks and it's the only one that works. It's a bit complicated for those not too technically savy, but just follow the directions. THANKS for the fix!!


RKK
December 14, 2007 4:05:10 PM

This fix works in Leopard. Actually only deleting CFMSupport, emptying trash, rebooting, reinstalling works.
December 20, 2007 8:47:17 AM

It doesn't work for me. I didn't find some of the Help folders on my machine; I found (and deleted) ~/Library/CFMSupport/HotSync\ Libraries, not the /Library/CFMSupport/Palm\ Conduit\ Library referred to; otherwise I followed the instructions carefully.

I find that (a) the first HotSync to Palm crashes -- reliably -- during the Calendar phase and (b) when I switch to the iSync conduit I sometimes crash, sometimes not but always fail to sync Contacts. It always crashes with iSync if I sync both Calendars and Contacts. It sometimes crashes if I sync one but not the other. Using slow synchronisation seems to make no difference. If I delete an item from my Address Book, I always get 128 'conflicts' which, as far as I can see, are identical between Address Book and Palm.

Because I wondered what a second sync would do, before switching (again) to the iSync conduit, I tried it. It hasn't crashed yet, but it seems to have got stuck (ten minutes) in Calendar.

So: no joy for me. Deleting all those files did help; repairing permissions first also helped (don't panic if you get a process using a lot of space and time even though Disk Utility says only 1 minute to go: it does finish); but still not what I need. :fou: 

Wish I'd done an Archive and Install when I switched to Leopard. :pfff: 
!