Fixing Incorrrect Function errors on USB pen drive

I have got a 16 GB pen drive from hp.
When I plug in the device a disk is detected as Removable disk(G:) and not the name I have given.
When tried to open it will show G:\ is not accessible Incorrect function.
when right clicked to check the property box, it shows
used space: 0 bytes
free space: 0 bytes
when checked for hardware, in properties, Generic USB Mass storage,its properties, it shows ' the device is working properly'.
When tried to format the Removable disk(G:), it doesn't work. when tried to scan it shows some files could not be scanned.
How can I rectify my pendrive?[quote[spoiler
4 answers Last reply
More about fixing incorrrect function errors drive
  1. Quote:
    Did you check the volume for errors under properties?

    Yes, i have clicked the check now option in the tools
    it opens the check disk removable disk, when I click stsrt button, the check disk removable disk window just dissappears and nothing happens.
  2. i have the same problem... my 8 Gb Kingston can't opened.. yea same like your problem.. plss if you have solve that problem please tell me... :cry:
  3. Hi,
    I have the same problem...if u have found a solution, please advise....
  4. hi i too have same problem with my pen drive so pls help me ............plese do me the favour
Ask a new question

Read More

Flash Media Removable Disk Devices Storage