Sapphire HD 4870 graphic corrupt...

I just bought the new sapphire HD4870 512MB graphic card. I realize it has problem playing some games. I have attached the screenshots of the graphic corruption problem as i dunno how to explain it just by words.

My system is running on Vista Ultimate 32bit SP1 and i just updated the card with the latest ATI Catalyst 8.12 driver.


What am i suppose to do ? Is it my graphic card having hardware problem or its something software related ? I could play other games like Crysis, Red Alert 3, Far Cry 2, Gears Of War and Bioshock without any problem though.


Game with corrupted graphic issues:

Bionic Commando Rearmed ---> Graphics corrupt
Supreme Commander Forged Alliance ---> Graphics corrupt
The Witcher ---> Graphics corrupt, similar like supreme commando and bionic commando rearmed but not as worst as them, still playable.

I tried the same game using the same disc on my friend's pc and it works great!! So, its definitely not the game's problem.

Help me...








10 answers Last reply
More about sapphire 4870 graphic corrupt
  1. Well, crap there goes my hopes it was a driver issue. I have the same exact card and have problems with it as well. I'm last ditch efforting with the cat 8.10 drivers and I'll let you know. I have the same card you have and a different model HD4870 also by sapphire except that one works. problem is crossfire locks my system up like a drum when I introduce the card that is same as yours.
  2. vram overheat.

    More airflow, make sure that the card has good contact with the heatsinks, if it persists just RMA it since it could be defective.
  3. ^^yeah, looks like vram corruption.
    is that non-reference cooler actually covering the vrams or are they without heatsinks and just under the airflow by themselves?
  4. Double checked and yes the heatsinks are in contact with the vram.
  5. Go into the CCC and under clock the card...... or hit - reset defaults. See if that helps.
  6. hello
    I am having the same problem with Forged Alliance on an HD3850, has this problem been resolved?
  7. I have the same card and had the same problem problem with forged alliance...I updated forged alliance and it was fine after that.
    oh yeah make sure you run in capability mode to XP
  8. No such luck for me, I am running windows 7 and I updated the drivers, updated the game, and I am running it in XP mode. I have the OC edition card so I clocked it down to default and no luck. Spore is also screwing up now, I got to get to the bottom of this. Thanks for your help.
  9. I have the same problem with forged alliance and my card is 2600 xt no oc, on win 7...tried with compatibility and nothing works...
  10. I found the solution for my problem!
    http://www.gpureview.com/forums/showthread.php?t=1121

    Maybe this will help one of you guys.
Ask a new question

Read More

Radeon Graphics Cards Sapphire Graphics